Support » Plugin: DreamObjects Backups » Latest Update 4.1.0 issues

  • Resolved modiphier

    (@modiphier)


    Hello,
    The latest update 4.1.0 is causing a couple of different issues with different site hosts.

    here is one error which is forcing me to have to delete the plugin folder to get the site back.

    Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /home/content/222/html/wp-content/plugins/dreamobjects/vendor/guzzlehttp/promises/src/functions.php on line 45

    some sites just display a 500 error page and i have to again delete the plugin.

    Just wanted to report my experiences.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    šŸ³ļøā€šŸŒˆ Plugin Review Team Rep

    What version of PHP are you on for these hosts?

    I may need to bump the required version to 7 at this rate šŸ™

    Thread Starter modiphier

    (@modiphier)

    yes, that could be the issue. It looks like the sites doing this are on godaddy hosting accounts. Just checking php info and it is 5.3.24. I upload the older version of the plugin I don’t know it might be 3.7 and it works fine but will it no longer work once the new server address has been moved?

    Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    šŸ³ļøā€šŸŒˆ Plugin Review Team Rep

    The 4.0 branch will work until June 21st, but this plugin has only supported PHP 5.5+ for 3 years now šŸ™

    It’s SUPPOSED to check and tell you that. Ask GoDaddy to update you to PHP 5.6, though, as 5.3 and 5.4 (and 5.5) are no longer supported by PHP.

    Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    šŸ³ļøā€šŸŒˆ Plugin Review Team Rep

    I made the checker smarter so it should now fail to run (and turn itself off) if you’re on old PHP.

    Please don’t use PHP 5.3, 5.4, or 5.5. They’re unsupported. All reputable hosts can update you. I recommend PHP 7. It’s much faster.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Latest Update 4.1.0 issues’ is closed to new replies.