Support » Plugin: Simple Calendar - Google Calendar Plugin » Latest update (28/12/2017) crashes WP

  • Auto update of plug-in ran while I was working on my site and immediately the whole thing came down – including admin section. Entire site inaccessible.

    Have had to access via host admin tools to remove the plug-in.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Zach Wills

    (@oxymoron)

    Hey @iainpurdie,

    I’m sorry that your site crashed due to the accidental release of the unfinished update. As mentioned in the other support thread (https://wordpress.org/support/topic/site-down-after-update-3/) there was a small window where the plugin update was available despite it not being ready.

    Please let me know if you run into any issues with the latest release (3.1.11). If you’re running PHP 5.4.45 or greater it should work without an issue- but please know that if there is an issue I’m keeping an eye on these threads and will attempt to help get it sorted ASAP.

    Regards,

    Zach

    2 sites out depuis mise à jour…
    J’ai désactivé simple calendar et tout remarche.
    Merci de corriger le bug 🙂

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @webxwebywebz

    Sorry you’re having an issue with the latest update. Do you happen to know what version of PHP you’re running? We discovered through a separate support thread that the required version of PHP is 5.5 or greater.

    We’re looking to push a hotfix today which will prevent sites from crashing due to an incompatible PHP version.

    Let me know if you run into more issues or need anything else.

    Regards,

    Zach

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @oneofalll

    You should be able to disable a plugin without access to the WP admin area using the following steps:

    1. Login to your site’s files using the file manager provided by your webhosting company or using an FTP program such as Filezilla.
    2. Browse to the /wp-content/plugins/ folder.
    3. Find the folder of the plugin you wish to disable (google-calendar-events in this case)
    4. Rename that folder to something different (like google-calendar-events_broken)
    5. Try to login to your WordPress site. You should get a message telling you that the plugin has been disabled.

    This article explains how you can disable a WordPress plugin when you don’t have access to your admin panel:

    There are other methods outlined as well (take a look at this article for reference: https://www.ostraining.com/blog/wordpress/disable-a-wordpress-plugin/), but if you are able to connect via FTP or through your hosting company the above should work for you.

    Let me know if there is anything else I can do to help.

    Regards,

    Zach

    I know how to disable plugin through the FTP.

    The question is, when you release the hotfixed version how should we proceed with the enabling/installing the plugin again and keep the configurations. Are they in the database or we should install again the plugin and make everything manually again ?

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @oneofalll

    Ah- gotcha. Your settings for the calendar should still be in the database. Removing the plugin files should not delete any of the Simple Calendar data from the site. The hotfix was released a few hours ago (version 3.1.11.1)- please try installing that and don’t hesitate to reach out if you continue to run into issues.

    You can find the latest release of the plugin here: https://wordpress.org/plugins/google-calendar-events/

    Regards,

    Zach

    The bug is in 3.1.11.1 too.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @oneofalll

    Can you specify which bug you’re seeing on your site? Is the site continuing to crash, or is there a different error? If you can provide any of the following it would help me get to the bottom of what’s going on with your setup:

    1. Link to screenshots of your calendar settings using a screen sharing service like Dropbox, Cloudup, or Jing/Screencast.
    2. PHP version that’s in use on the server.
    3. Paste in the shortcode and event builder codes you’re using.
    4. Create and link a test page with the issue so we can take a look.

    Regards,

    Zach

    There is no error, only the page with the information that I have upgraded to 3.1.11.1 with all fancy information about the plugin and when I click on different section, for example Settings, Themes or Plugins I was redirected again to the successfull installation/upgrade page of the plugin.

    The PHP version of the server is 7.0.19.

    If you want I can share image but this won’t help you at all because you know how the upgrade page looks like. Even when I click on a button on this page I am redirected to the same page.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @oneofalll

    That redirect happens if a transient is found in the database. When you view the upgrade page it should automatically delete that transient which would prevent the redirect from happening again. I’m not quite sure what’s going on in your installation, but we might be able to work around that.

    Are you able to run PHP? If so, the following line of code should remove the transient:

    delete_transient( '_simple-calendar_activation_redirect' );

    If you can’t run PHP but have access to the database, you can check in there for the transient and delete it. It should be in the options table with an option_name of _transient__simple-calendar_activation_redirect.

    Same issue here. Once the plugin is being reactivated, one cannot access the admin page anymore… 🙁 happened after installing the latest update.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @jornleyssens

    To confirm: are you running into the same issue with being redirected to the upgrade page? Is it possible for you to attempt one of the workarounds in my previous post for deleting the transient (https://wordpress.org/support/topic/latest-update-28-12-2017-crashes-wp/#post-9831772)?

    We’ll look into this more tomorrow to see if we can replicate the redirect bug. Do you happen to know what version of the plugin you were upgrading from?

    Regards,

    Zach

    I’m simply not able to log in to the admin area anymore, only the error Too_Many_Redirects appears… I can disable all plugins by renaming the plugin table via FTP. By one-by-one reactivating the plugins, I came to find that the simple calendar is the one causing the issue.
    I checked for this transient thingy, but couldn’t find any in the options table.

    After upgrading to v3.1.12 everything is working fine. Thanks for the fix, whatever it was… 🙂

    Jorn

    I stripped the plug-in out via file manager on the host’s control panel and simply haven’t re-installed.

    Yeah, 3.1.12 works fine. Thanks for the fix.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this review.