Support » Plugin: Strong Testimonials » Latest Update 2.41.1 breaks custom view templates

  • Resolved shaunbowen

    (@shaunbowen)


    Hi There, I updated to the latest version of Strong Testimonials on one of my sites this morning and I started seeing some broken code on my Testimonials.

    The code that has stopped working properly seems to be wpmtst_the_title(). I have deleted that from my custom template now, but I wonder why it used to work and now doesn’t?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support mplusb

    (@mplusb)

    Hi @shaunbowen,

    Sorry for the trouble!
    Go to your template and look for the functionwpmtst_the_title( '<h3 class="wpmtst-testimonial-heading testimonial-heading">', '</h3>' ); and replace it with <?php wpmtst_the_title( 'h3', 'wpmtst-testimonial-heading' ); ?>

    This should fix it.

    Warmly,
    Mihaela

    Hi There,

    Thanks for the reply. Could you tell me if this change affects any other areas of our custom templates? If so it would be useful to have a guide showing what we will need to update, to save anything else breaking when we update.

    Plugin Support mplusb

    (@mplusb)

    Hi @shaunbowen,

    No, it does not.
    The only thing that changed is how the function wpmtst_the_title works.

    Warmly,
    Mihaela

    shaunbowen

    (@shaunbowen)

    Unfortunately I’m now seeing on other sites (without custom templates) that the default <h3> testimonial heading is showing up despite deselecting it in the “view” settings.

    I think the code that checks whether the ‘Title’ field is checked is not being honoured by the templates any more.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.