Support » Plugin: Smush - Lazy Load Images, Optimize & Compress Images » Latest Smush on Latest WP > lazy load not loading images

  • Resolved gab81

    (@gab81)


    hi,

    I have just updated my small website to latest WordPress 5.8 and by updating plugins one by one, i noticed that with Smush’s latest update to 3.8.8 the Lazy Load functionality causes photos not to load anymore.

    I tested this by disabling the plugin and images work, but then going specific i had a feeling it was the Lazy Load so i disabled just that option in Smush and images do load.

    Why is this happening? In the previous release of WP with the previous relesae of Smush, can’t remember which one i had earlier sorry – this didn’t happen and i had all options checked.

    I have the free Smush version.

    thanks,
    Gabrio

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Kris – WPMU DEV Support

    (@wpmudevsupport13)

    Hi @gab81

    I hope you are doing good today.

    I was not able to replicate this issue in my lab site. Could you create a staging site and enable a default WP theme like 2019 and see does issue exist still?

    Also, was there any other updates on the site, like plugins and theme update?

    Kind Regards,
    Kris

    Thread Starter gab81

    (@gab81)

    thank you for the reply – well the thing is that i updated a bunch of other plugins and everything worked OK, with the latest WP version, then when i updated smush the images didnt load.

    we also restored a previous backup to a previous state and in fact everything works OK.

    But i did some troubleshooting and found the following:

    on the Lazy Load settings, i have everything checked and this is what breaks images on my site:

    Output Locations
    By default we will lazy load all images, but you can refine this to specific media outputs too.

    > Content
    > Post Thumbnail

    I tested it and when you tick these ones (turned on) then images don’t load anymore. The first (content) doesn’t load images on a post while the second one Post Thumbnail doesn’t load images on the homepage. So i disabled them now,

    If you want a list of all my plugins for seeing what is conflicting with what, please drop me a DM.

    Regards,
    Gabrio

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @gab81

    Thank you for the update.

    Just to confirm, are you using the Native Lazy Load option?

    If not, could you please go to Smush > Lazy Load, enable the Native Lazy Load also move the script to the header to check if makes any difference?

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter gab81

    (@gab81)

    hello

    i tested that just now and whether i have it enabled or not, what makes a difference if i check

    Post Thumbnail
    Content

    When those are enabled, i have no images on my site.

    I left Native Lazy enabled now, i get a bit higher scores on PSI

    thanks,
    Gabrio

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @gab81

    Post Thumbnail
    Content

    This can indicate your theme has a native Lazy Load, you could send us some URLs to check the source code where you get the missing images so we can confirm if those are being Lazy Loaded by default.

    Best Regards
    Patrick Freitas

    Thread Starter gab81

    (@gab81)

    sure, i can – would prefer to send that in DM or email, where can i send that to you?

    thanks,
    Gabrio

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @gab81

    Could you please send me an email to contact@wpmudev.org using this template:

    Subject: "Attn: Patrick Freitas"
    
    Message: link back to this thread for reference https://wordpress.org/support/topic/latest-smush-on-latest-wp-lazy-load-not-loading-images/

    Best Regards
    Patrick Freitas

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @gab81 ,

    We haven’t heard from you for a while now, so it looks like you no longer need our assistance.

    Please feel free to re-open this ticket if needed.

    kind regards,
    Kasia

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Latest Smush on Latest WP > lazy load not loading images’ is closed to new replies.