Support » Fixing WordPress » Latest posts will not show up on homepage

  • Resolved argraham214

    (@argraham214)



    Hi,

    I’m hoping someone can help me with this.

    I created nearly a dozen posts yesterday on my website, but for some reason they are not showing up on my front page. The new posts are on the site, and I can still access them by searching for the titles and tags on the site. Once I log in to the site, they show up again, and they show up on mobile as well. But for anyone just visiting the site, none of my new posts are there.

    On the dashboard, my settings are set to display my latest posts on the homepage. I’ve already tried refreshing the browser cache, but there’s no change. The version of WordPress I’m running is 4.9.8 and the theme I’m using is MH Newsdesk. I have about 27 plug-ins, but I haven’t made any changes to them recently, although a few that are unrelated to blog posts need to be updated.

    The most recent posts should be a blank photo titled “Rambler-8-11-18.” Any ideas? Any and all help would be appreciated.

    • This topic was modified 2 months, 1 week ago by  argraham214.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    For us your latest posts are displaying just fine, including the most recent “Rambler 8-11-18” post (screenshot)

    @mh-themes,

    Let me ask you another question. The most recent posts are showing up again, but now there is other content missing from the front page. Specifically, I’m missing a video widget and a bunch of columns that were originally on the front page. The recent posts showed back up on their own, and I did not delete anything off the front page during the process. Any idea how this could have happen and how I can get those widgets back?

    For reference, I’ve included screencaps of my other site that uses the same theme, DFW Newsflash, to better illustrate what’s missing. The content circled in red is the content that is missing from the Rambler site.

    DFW Newsflash Homepage
    Screencap 1 – Video widget
    Screencap 2: Home Column Content

    These are just widgets. So if you haven’t removed the widgets by yourself, they still will be there (widgets don’t disappear by themselves). If not, you can just place them again in your WordPress dashboard under Appearance => Widgets.

    However, the reason why the widgets on this particular site aren’t displaying is because you’re showing your latest posts on your front page (archive). Instead you need to create and set a static front page and select the Homepage template for the static front page. This all is covered in the theme documentation.

    Also, whenever your latest posts are not showing up, this pretty much sounds like a caching issue. If you’ve not cached your site by yourself (e.g. through a caching plugin), then you could contact your hosting company as they might be caching the site on their end.

    By the way, it seems you’re using a premium theme which isn’t supported through the forums on WordPress.org. If you own a valid license and have any questions, you can send a support request here.

    @mh-themes,

    It looks as though my settings were indeed set to “Your latest posts” in Settings = > Reading. I switched it to a static homepage as you suggested and it looks like everything’s back to normal.

    However, when I log out of WordPress and view the site normally, it still shows the “Your latest posts” page and not the correct Homepage. Was there something I forgot to do?

    However, when I log out of WordPress and view the site normally, it still shows the “Your latest posts” page and not the correct Homepage.

    That means your site is cached and you need to clear the cache (incl. your browser cache). If you’ve not cached the site by yourself (e.g. by using a caching plugin), then your hosting company might be caching the site on their end and you can contact them for further assistance.

    • This reply was modified 2 months, 1 week ago by  MH Themes.

    That seems to have done the trick. Thanks so much all your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.