Latest post page removes h2 formatting of sub-title (4 posts)

  1. vanmoore
    Posted 2 years ago #

    My site is micheldory.com.

    On the front page I have the latest posts. The post is set with a title in which you see on the page very well, h1.

    When configuring the posts, The title is set (h1) and then I have a sub-title (h2). But looking at the first page on the site, you see the h1 title but the h2 title has the formatting removed so it takes on the formatting of the paragraph and removes the return. But clicking to the post, it is displayed correctly.

    How can I get the h2 to show the formatting on the home page like it shows on the post page?

    Thanks ahead for your help.

  2. anefarious1
    Posted 2 years ago #

    I think I understand what you mean. Your theme takes info from your latest post and uses it for automatically creating an H2 title on your front page (home page) which is not what you want.

    I have this same problem, I use Thesis theme, but I don't know how to fix it. Anyone?

  3. c.bavota
    Theme Author

    Posted 2 years ago #

    That is because your home page is displaying the excerpt and by default, WordPress strips all formatting out of the excerpt. What you can do to work around this is copy the excerpt text you want to use, including your H2 tag and paste it into the custom Excerpt box. You should see the box below your text editor. If not, click on Screen Options in the top right and check the appropriate box.

  4. anefarious1
    Posted 2 years ago #

    hello c.bavota,

    Thank you for your idea. I think you are onto something. However, the static homepage, which contains the excerpts of recent posts, doesn't have a standard text editor where I can input a custom excerpt box.

    The posts, including the most recent post where the data is being pulled from, does have a text editor but would that help in this case?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic