Support » Plugin: MC4WP: Mailchimp for WordPress » Latest plugin update crashing 2 of my sites

  • Resolved garydee1977

    (@garydee1977)


    Guys – installed latest Mailchimp plugin – crashing two of my sites.

    Found it to be your plugin – when I reenable it again I get this error:

    Parse error: syntax error, unexpected ‘)’, expecting :: (T_PAAMAYIM_NEKUDOTAYIM)

    in /home/SITEUSERNAME/public_html/wp-content/plugins/mailchimp-for-wp/includes/functions.php on line 69

Viewing 6 replies - 1 through 6 (of 6 total)
  • Lucas Karpiuk

    (@karpstrucking)

    Ran into this today also. Rolled back to previous version for the time being.

    garydee1977

    (@garydee1977)

    Yes I’ve just disabled it myself til a patch is brought out.

    Plugin Author Danny van Kooten

    (@dvankooten)

    Hey guys. We’re sorry that happened to you. Our previous plugin update contained a bug for people that were running an older PHP versions and our tests didn’t catch it. Again, sorry… 🙁

    I’ve just pushed out version 4.3.1 in which the issue is fixed.

    If you’re still having the issue, please go into your /wp-content/plugins/ folder and delete or rename the mailchimp-for-wp directory to get your website back-up. You can then re-install the latest version again.

    On a somewhat related note: I strongly suggest asking your webhost to upgrade you to a PHP version that is actively supported. Your sites are at a security risk running such an old version (PHP 5.4 has been unsupported for over 3 years at the time of writing).

    Not only that, but updating to PHP 7.x will greatly improve your website’s performance. Double the performance without any further changes required is not unheard of.

    Lucas Karpiuk

    (@karpstrucking)

    @dvankooten thanks for the patch, we’ll let our affected customers know about their PHP version.

    Can’t sign into my website dashboard because of the new plugin. I recall there being another way to get into my site to fix if anyone can help me!!

    Parse error: syntax error, unexpected ‘)’, expecting :: (T_PAAMAYIM_NEKUDOTAYIM) in /home4/tstack/public_html/wp-content/plugins/mailchimp-for-wp/includes/functions.php on line 69

    Hey @tstack,

    You can connect via ftp, browse to the plugins folder (eg. wp-content/plugins), then rename or move the folder temporarily. That should get the site back online.

    Then log in and navigate to the plugins page, this will deactivate the plugin.

    Then move or rename the folder back to original and refresh the plugins page. Then delete the plugin.

    From The plugin page you can download the older version of the plugin and then install the downloaded older version via the upload plugin option.

    Hope that helps!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Latest plugin update crashing 2 of my sites’ is closed to new replies.