WordPress.org

Forums

Crayon Syntax Highlighter
[resolved] Latest patch puts all forum posts into code brackets (11 posts)

  1. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    The latest update put all of the content in every forum post into forum brackets for highlighting. Anyone else getting this?

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

  2. Juanfra Aldasoro
    Member
    Posted 2 years ago #

    Yes - I'm having the same issue :(

    Also, whenever I have some html + php it puts a blank space between the question mark and the php, i.e.: <? php

    So, when users copy the code I post they always get it wrong.

  3. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Fixed in the latest beta, will release today!

    Juanfra, could you please specify a URL so I can test it out?

  4. Juanfra Aldasoro
    Member
    Posted 2 years ago #

    Thanks :) I've updated to the new version and it's working now.

    You can check the blank space here http://nicethemes.com/forums/topic/customize-copyright-line/#post-973 - I'm not sure if it is something with the plugin or wp.

    Thanks again, your plugin is great.

    Juan.

  5. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    When attempting to upgrade I get this:
    "Plugin could not be activated because it triggered a fatal error."

    Can't investigate further right now.

  6. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    @Juanfra I suspect it might be wordpress - I've tested it and the code you have works fine for me. Could you disabled other plugins and also make sure the content is correct in the HTML view of the post editor? Also try to turn off "WordPress should correct invalidly nested XHTML automatically" in WP admin > Settings > Writing.

    @Erlend I'll look into this. Make sure the zip isn't corrupt?

  7. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    @Erlend I'm afraid I can't reproduce it with the latest zip from WP Extend. Are you able to look into your PHP log? If some PHP files are missing or corrupt during upload/extract it's likely to cause that issue as well.

  8. Juanfra Aldasoro
    Member
    Posted 2 years ago #

    Hey there, thanks for taking the time and check my issue. I'll continue looking at this. That setting is unchecked.

    Thanks again,
    Juanfra.

  9. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Righto, I'll mark this particular issues as complete then.

  10. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    I finally had time to look into it more carefully and I found the culprit:
    http://wordpress.org/extend/plugins/search-bbpress/

    After disabling this plugin, Crayon Syntax Highlighter activated normally. Naturally we should not have been using a plugin this old in the first place. Sometimes WordPress backwards compatibility does more harm than good...

  11. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    Ah interesting, I'll take a look in any case and see if I can resolve the conflict. Perhaps activating Crayon and then reactivating this plugin will do the trick.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Crayon Syntax Highlighter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.