Support » Plugin: User Registration, Login Form, User Profile & Membership ā€“ ProfilePress (Formerly WP User Avatar) » Latest minor version causing ALL profiles to redirect to Home Page!

  • Resolved BlueSteam

    (@bluesteam)


    Hello

    Since the latest release on Sunday from version 3.1.3 -> 3.1.4 all my members profile pages are redirecting to the HOME page.

    I suspect it is due to this enhancement that was released in the latest update:

    https://plugins.svn.wordpress.org/wp-user-avatar/trunk/changelog.txt

    * Enhancement: when a user profile doesn’t exist, redirect to homepage.

    The moment I disable this plugin, the profile pages load perfectly fine! If I activate this plugin, the profile pages redirect to the home page.

    BEFORE this version everything was working 100%

    We use Paid Memberships Pro for our memberships together with the WP User Avatars (now called ProfilePress.

    Please can support assist here?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter BlueSteam

    (@bluesteam)

    So I have performed tests and rollbacks and found that the NEW ProfilePress from version 3.x caused all these problems.

    From Version 3.0 -> 3.1.3 it would redirect to the login screen whenever someone tried to access the profiles.

    I suspect that the developers also figured this out and they release the new enhancement in version 3.1.4 for redirecting to the home page instead.

    Going back to WP User Avatar 2.2.16 everything is working 100% again!

    So what now??

    Plugin Author Collins Agbonghama

    (@collizo4sky)

    If you will like us to work with you on resolving this issue, please open a ticket via https://profilepress.net/support/

    Thread Starter BlueSteam

    (@bluesteam)

    Thanks Collins

    I have opened the ticket

    Plugin Author Collins Agbonghama

    (@collizo4sky)

    Responded. Let’s continue the conversation over email.

    Thread Starter BlueSteam

    (@bluesteam)

    Sure, Thanks Collins….much appreciated that you are taking the time to assist with this. šŸ˜€

    Thread Starter BlueSteam

    (@bluesteam)

    Thank you for the fix! šŸ˜€ Turns out it was a setting that conflicted with the PMPro plugin. PMPro uses profile as their slug and so does ProfilePress.

    So the setting was there to simply change the word profile to something else which fixed the problem.

    Thanks Collins!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.