Support » Plugin: Genesis Connect for WooCommerce » Latest GCW 0.9.10 displays blank Shop Page

  • Resolved Brian North

    (@aspasa)


    On installation of GCW ver. 0.9.10 my WC Shop Page has now become 100% blank (devoid of any & all content) for site visitors.
    When logged in to the WP Backend (as an admin) the WC Shop Page shows only a blank admin menu, my Site Header and also Main Div.. The <ul class=”products”> div should be showing 12 Products but is blank. No Footer or Sidebar either.
    Genesis: 2.5.3
    Dynamik: 2.3.4
    WC: 3.2.6
    GCW: 0.9.10
    Any suggestions for recovering my Shop would be helpful at this point. Thank you.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 36 total)
  • Me too.

    2018-02-01T02:12:44+00:00..Error: Call to undefined function wc_get_loop_prop() in ..wp-content/plugins/genesis-connect-woocommerce/lib/template-loader.php:268
    Stack trace:
    #0./genesis-connect-woocommerce/templates/archive-product.php(88): genesiswooc_content_product()
    #1./wp-includes/class-wp-hook.php(286): genesiswooc_archive_product_loop('')
    #2  wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #3 /wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #4 ../themes/genesis/lib/framework.php(38): do_action('genesis_before_...')
    #5 /genesis-connect-woocommerce/templates/archive-product.php(94): genesis()
    ...
    Plugin Contributor Nick C

    (@modernnerd)

    @aspasa @moneyhome You can try visiting example.com/wp-admin/admin.php?page=wc-settings&tab=products and resaving settings there.

    The issue relates to a change in the WooCommerce plugin: https://github.com/woocommerce/woocommerce/issues/18683.

    Same here, and above re-resave does not solve the problem.

    Reverting back to 0.9.9 resolves.

    Thread Starter Brian North

    (@aspasa)

    @modernnerd – tried resaving WC settings as suggested but, no happy:(

    Thread Starter Brian North

    (@aspasa)

    could I get a link to 0.9.9 pls.?

    Plugin Contributor Nick C

    (@modernnerd)

    Thank you for trying that. It would also be worth checking that shop and product pages are still set in your WooCommerce settings.

    Otherwise, 0.9.9 is available from the download link at the bottom of this page while this is investigated further: https://wordpress.org/plugins/genesis-connect-woocommerce/advanced/

    Thread Starter Brian North

    (@aspasa)

    @modernnerd – tried resetting other pertinent and relevant pages but still no happy:} but, thanks for the prior version link – that works again now.
    @michaelgracie – thanks for the 0.9.9 solution. works for me!
    (and, thanks to whomever’s checking from hinet.net in Taiwan!)

    • This reply was modified 4 years, 6 months ago by Brian North.

    Just to chime in here, I’m having the same problem, none of the suggested fixes for 0.9.10 worked, so I rolled back to 0.9.9 and everything is back to normal.

    Plugin Contributor Nick C

    (@modernnerd)

    Has everyone who reported this updated WooCommerce to 3.3.0+ before updating Genesis Connect to 0.9.10?

    If you’re running an older version of WooCommerce you will need to update it to 3.3 (or higher) before updating Genesis Connect to 0.9.10.

    If you still see the issue with WooCommerce 3.3 installed, please feel free to follow-up here.

    Nick – first thanks for the great plugin and working on this.

    I’ve been looking for a fix and found this added to the top of the WooCommerce 3.3 update announcement URL: https://woocommerce.com/2018/01/whats-new-woocommerce-3-3/

    We’ve delayed tagging WooCommerce 3.3 as stable while we resolve some template changes affecting popular themes. In the meantime, you can read all about the new features in 3.3 coming soon below.

    That wasn’t there yesterday. I also can no longer update to WooCommerce 3.3 on some of my sites. Sounds like the WooCommerce dev team is hard at work on 3.3.1 to fix some issues so they pulled down the WooCommerce 3.3 update for the time being.

    Plugin Contributor Nick C

    (@modernnerd)

    Yes, @vwondra, and sorry for the confusion there. Automattic rolled the WooCommerce update back from 3.3.0 to 3.2.6, so it’s not currently possible to update to 3.3.0.

    If you’re using WooCommerce 3.2.6 with Genesis Connect 0.9.10, the best option for now is to download Genesis Connect 0.9.9 from the link at the bottom of https://wordpress.org/plugins/genesis-connect-woocommerce/advanced/.

    When Automattic re-releases WooCommerce 3.3.0 (probably as 3.3.1), you can then update to Genesis Connect 0.9.10.

    Thank you! I had the same issue and was confused because my WooCommerce was only at 3.2.6 and their forums were talking about 3.3 being the issue.

    Luckily I had a site backup from this morning so I just restored and updated everything but Genesis.

    I will wait for the fix to come from Woo before updating!

    Hi,
    I am having the same problem!! How do you revert back to Genesis Connect 0.9.9. from 0.9.10 ?

    I am not very computer savvy but I downloaded 0.9.9 as suggested and tried to upload it to wordpress by installing it as a plugin. It did not work. Message reads that the “Destination Folder already exists”.

    So I deactivated 0.9.10 in Plugins and tried again…..Same message but my shop is now back although it looks different.

    Then I went to Genesis Import/Export and tried uploading 0.9.9 there. Not sure if I was supposed to try it that way but that did not work either.

    I am sure there is a simple way to do this. Could someone help me out?

    Thank you,
    Michele

    Easiest way is to just delete/uninstall Genesis Connect version 0.9.10, and reinstall version 0.9.9 in it’s place.

    I´m having the same “blank shop page” in https://acampadaysenderismo.com/

    for the moment I downloaded the previous version and the problem has been solved.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘Latest GCW 0.9.10 displays blank Shop Page’ is closed to new replies.