Support » Plugin: Subscribe2 » Latest beta code has more problems

  • Resolved


    So I just installed your latest beta code for WP 3.5 and have another bug to report. I’m unable to sign up new Subscribe2 user email addresses. I get the proper screen for the sign up. I enter the email address, press “subscribe” and then instead of getting the normal pop-up box telling me that a confirmation email is on the way, I’m getting sent back to the static home page with no popup box at all, and no evidence inside any of the Subscribe2 tools that the new email user is anywhere in the blog database.

Viewing 10 replies - 1 through 10 (of 10 total)
  • @kurtatwork,

    Are you using the ~Widget or the form deployed on a page?
    Does this happen with a default WordPress theme and all other plugins deactivated?
    Have you checked that AJAX is enabled in the Settings?

    Using your form:

    The WordPress theme is 2010 v1.3

    Only two other plugins are active right now, Whoopra and Grid Columns. When I deactivate them, the problem is still there.

    AJAX is always enabled.


    Thanks for posting the link – it helped.

    It’s a configuration issue in Subscribe2->Settings, the form is deployed here:

    But the after submission the user and form are directed here:

    In Subscribe2->Settings under the Appearance heading look for where it says “Set default Subscribe2 page as ID” and select the Email Signup page in the dropdown list and save thouse settings. Then try again.

    Thanks, that worked! When we upgraded Subscribe2, it must have picked up the wrong page for that setting, since it was never directed to go there before.

    OK, so I’m getting the proper “email notification has been sent” message now, but the email is not being generated and sent to the specified new email signup address.

    When I go into the Subscribe2 subscriber list, I see two new unconfirmed email addresses appearing in red.


    Failed emails could be down to configuration again but only combined with hosting restrictions, or it could be just the latter.

    The emails need to be sent from a real email address that ends with Make sure you have an administrator level WordPress user with an email address like that and then select that account as the sender in Subscribe2->Settings under the Emails Settings heading where it says “Send Email From:”.

    Yup, I definitely made sure the sending email account was the site admin and was a “good” email address. Its been this way and working fine until WP 3.5

    Hmmmm, I deleted the new users which were not getting notification messages. Then I went into all of the settings panels and “saved” everything again, including the WP admin user email screen. I got one of the them to almost work. I went over to Gmail, opened the email, clicked on the confirmation link in the email from the blog, I get this on the blog itself:

    Subscription Confirmation

    No such email address is registered.


    It seems like there may be a delay (perhaps some queuing) in the sending of emails on the server then and you have erased the record from the system for the email that did arrive.

    I got the gmail account working. There does appear to be some queuing taking place for the other account, resulting in a very long delay in getting the confirmation email to appear in that inbox.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Latest beta code has more problems’ is closed to new replies.