WordPress.org

Support

Support » How-To and Troubleshooting » Latest article not showing

Latest article not showing

  • Dear WordPress support,

    I have published a site on a test url, everything works fine apart from one page I have set to appear a certain category of posts but the most recent post does not appear, if I post another article under that category it pushes the second to last one on the page but still doesn’t show the most recent one I posted..

    http://www.scriptposter.com/new/category/gallery/

    It pulls it though fine on the homepage tho,

    Home
    http://www.scriptposter.com/new/

    Here is the code I am using :

    <?php while ( have_posts() ) : the_post() ?>
            <div class="secondColumn">
            <div class="blogFeatureWorkImage"><a>"><?php the_post_thumbnail('small-thumb'); ?></a></div>
             </div>
             <div class="thirdColumn2">
        	 <div class="blogFeatureWorkContent">
                    <h1 class="articleTitle"><span class="yellow"><a>"><?php the_title();?></a></span></h1>
                	<p><?php the_content();?></p>
             </div>
             </div>
             <div class="clear"></div>
            <?php endwhile; ?>

    [please remember to mark any posted code – http://codex.wordpress.org/Forum_Welcome#Posting_Code – the above section is already partialy corrupted by the forum parser]

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Hi There, thanks for your reply..

    I tried the Plugins but that didn’t change anything, so I tried the 20 ten theme and it then does pull it through.

    http://www.scriptposter.com/new/category/gallery/

    so how do I work out why my theme isn’t pulling it through, any ideas?

    esmi

    @esmi

    Forum Moderator

    Where did you download this theme from?

    It’s a bespoke theme I’ve built from scratch I’m a web designer, I’ve built plenty of themes and I’ve never come across any problem like this.. It’s so strange I can’t work out what’s causing it at all!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Latest article not showing’ is closed to new replies.
Skip to toolbar