Latest article not showing (5 posts)

  1. bmdesign
    Posted 3 years ago #

    Dear WordPress support,

    I have published a site on a test url, everything works fine apart from one page I have set to appear a certain category of posts but the most recent post does not appear, if I post another article under that category it pushes the second to last one on the page but still doesn't show the most recent one I posted..


    It pulls it though fine on the homepage tho,


    Here is the code I am using :

    <?php while ( have_posts() ) : the_post() ?>
            <div class="secondColumn">
            <div class="blogFeatureWorkImage"><a>"><?php the_post_thumbnail('small-thumb'); ?></a></div>
             <div class="thirdColumn2">
        	 <div class="blogFeatureWorkContent">
                    <h1 class="articleTitle"><span class="yellow"><a>"><?php the_title();?></a></span></h1>
                	<p><?php the_content();?></p>
             <div class="clear"></div>
            <?php endwhile; ?>

    [please remember to mark any posted code - http://codex.wordpress.org/Forum_Welcome#Posting_Code - the above section is already partialy corrupted by the forum parser]

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. bmdesign
    Posted 3 years ago #

    Hi There, thanks for your reply..

    I tried the Plugins but that didn't change anything, so I tried the 20 ten theme and it then does pull it through.


    so how do I work out why my theme isn't pulling it through, any ideas?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Where did you download this theme from?

  5. bmdesign
    Posted 3 years ago #

    It's a bespoke theme I've built from scratch I'm a web designer, I've built plenty of themes and I've never come across any problem like this.. It's so strange I can't work out what's causing it at all!

Topic Closed

This topic has been closed to new replies.

About this Topic