WooCommerce - excelling eCommerce
Lastest Woocommerce Update wont allow attributes? (10 posts)

  1. mkeegan@axvault.com
    Posted 1 year ago #

    I installed the latest woocmmerce update and now the attributes section does not work. When we try and edit an old product it wipes out the attributes. When you copy a post nothing moves over.


  2. Apfelbiss
    Posted 1 year ago #

    That sounds similar to me.

    Recently I updated WordPress and WooCommerce, but I can not say for sure if this problem didn't exist in the last versions before the updates.

    When creating products with variations as explained, no drop-downs (and so no “Add to Cart”-button) is shown. It's not an empty drop-down, it's an empty html-table without drop-downs and drop-down labels:

    <table class="variations" cellspacing="0">
    <tbody> </tbody>

    At the same time, an old variable product worked well. But after saving it (without any changes), now there is also no drop-down in the front-end.

    I changed the theme to 2013 and deactivated all plugins (except WooCommerce), but the problem still exists, even after re-changing this.

  3. Roy Ho
    Posted 1 year ago #

    Did you make sure each and every variation has a price set for it?

  4. mkeegan@axvault.com
    Posted 1 year ago #

    Yes each variation has a price. But the attributes won't save. I went to the developer and the fixed the code, but it still does not work on our end. Why would an update send my product post off. I don't understand

  5. Apfelbiss
    Posted 1 year ago #

    @ mkeegan:
    Does that mean the products even have no attributes in the back-end?
    My problem only exists in the front-end.

    @ splashingpixels:
    Yes, I tried many ways: Normal and bulk edit, same and different prices, with and without sale prices. But it amazes me most, that this problem even occurs at re-saved products. Why did it worked before the re-save without any changes?

  6. mkeegan@axvault.com
    Posted 1 year ago #

    Yes that is exactly it. Same problem. They do not save and do not display on the backend.

  7. Roy Ho
    Posted 1 year ago #

    Hmmm I just tested it on my end resaving some of the attributes and I am not seeing any issues.

    Were any of your products imported?

  8. Apfelbiss
    Posted 1 year ago #

    Yes, I ex- and imported some products „WooCommerce Product CSV Import Suite” for testing. But the last products are created in the back-end. And it seems that all products have got this problem.

    Did you even re-saved some variable products (and not only the attributes)?

    But now it works, with regular and user-defined attributes. Unfortunately I can't say why. I shut down my computer yesterday, but our local server (where the site currently is hosted with MAMP) wasn't restarted.

  9. mkeegan@axvault.com
    Posted 1 year ago #

    I tried the All Import Plug in and with a CSV and it left characters unreadable by JS.

    I guess the programers did not fix the glitch.

    No none of the products were imported. But I did use the WP all import plug and it did left characters unreadable by JS. We deleted everything associated with it. Then we updated and now we cannot save any attributes.

  10. Shewsterchris
    Posted 11 months ago #

    Hi thought i would just add to this post, as this problem had me very annoyed.

    In my case, i deactivated both WP all import as well as the woocommerce add-on,then re activated it. This worked for me and i did not lose any of my templates. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic