Support » Fixing WordPress » last WPs compatible with IE7, 8 and 9 ?

  • Hello,

    I’m considering using WordPress as a base for a website who needs a good retrocompatibility with IE. I have some questions please.

    A – Can you tell me which are the last WordPress versions fully compatible with IE 7, IE 8 and IE9 please ?
    B – Can you also tell me which is the oldest IE fully supported by the current version of WordPress ?
    C – Can you tell me if there is a place where I can read these infos on the Web ?

    I indeed have in mind that finding compatible plugins and themes for older WP versions can be tough.
    D – Can you pinpoint a place where I can find nice templates and plugins compatible with older versions of WP ?

    I hope someone can help for at least some of these questions.

    Thank you for your attention, my best regards.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    Older versions of WordPress will have highly publicized, easily exploitable security vulnerabilities. Using anything but the current version of WordPress is just asking for your site to get hacked.

    What’s the rationale for trying to be IE compatible that far back?

    In the past my client paid to have webapps developped according to their needs and their compatibility was granted until IE7. They can’t install multiple versions of IE in the computers using these apps. And the upgrade time and cost for these old applications (which are still working flawlessly) is huge compared to this project’s budget.

    This is why many institutions are still using IE6 and 7 :/

    Thank you, I will transfer your answer to my client. I’m still hoping that someone can answer my four questions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘last WPs compatible with IE7, 8 and 9 ?’ is closed to new replies.