Support » Plugin: Appointments » Last Update took my site down

  • Hi support,

    I received this error message after the last update

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Appointments’ does not have a method ‘post_ceontent’ in /home/devknssconsultin/public_html/wp-includes/plugin.php on line 235

    How do I fix this as soon as possible because it took down the entire site and that is the only message on the home screen.

    see here

    http://screencast.com/t/dT7tIuYYFfM

    I had to disable the plugin for now until this is fixed. which I need to book appointments for clients.

    Thank you for your help

    https://wordpress.org/plugins/appointments/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey there knssconsulting,

    Hope you’re well today 🙂

    As I already mentioned in couple of previous threads, you’re suing premium version of the plugin so please open a thread on WPMU DEV forum here so we can investigate this further.

    Cheers,
    Bojan

    Hi Bojan,

    There is a ticket in the WPMU DEV forum

    https://premium.wpmudev.org/forums/topic/breaking-stuff-with-multiple-errors

    Can you take a look at it.

    Plugin Contributor Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again knssconsulting,

    I apologize for the delay on that thread, I’m not really sure why this one wasn’t displayed in the “no response” feed.

    I’ve notified my colleague so he can respond there 🙂

    Cheers,
    Bojan

    Thanks Bojan,

    Your colleague responded and we responded back. Just waiting to find out the fix for the issue.

    I don’t have access to the form because it’s my web developer who has access.

    If you can update your colleague that the error came for my site as well after the last update. Also I tried disabling all the plugins and just activated Appointment+ and same issue. The error cam up and took down my site.

    Thank you

    Plugin Contributor Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again,

    Looks like one of my colleagues managed to replicate the error and offered a solution there 🙂

    Cheers,
    Bojan

    Thanks Bojan,

    My concern is when I do that fix it will be an issue when the developers push a new update down. Do you know what I mean?

    I see in the post he mentioned

    “I changed the following line in: wp-content/plugins/appointments/appointments.php

    add_filter( ‘the_content’, array( &$this, ‘post_ceontent’ ), 100 ); // Serve this later than do_shortcode

    to say ‘post_content’ and it works”

    Just to confirm he changed that code in the appointments.php file to

    ” add_filter( ‘the_content’, array( &$this, ‘post_content‘ ), 100 ); // Serve this later than do_shortcode “

    Which I did try the fix and it did resolve the issue. Was this just a spelling mistake by the coders? And with the next update will the developers. Make sure this issue is resolved?

    Thank you

    Plugin Contributor Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Hey again,

    Thanks for the update and glad to hear that you fixed the problem. This is most likely an error in the plugin and we already forwarded that to our developer so it will be included in the following version of the plugin 🙂

    Best regards,
    Bojan

    Thanks Bojan for your help I really appreciate it.

    Plugin Contributor Bojan Radonic – WPMU DEV Support

    (@wpmudev-support4)

    Glad I could help 🙂

    Cheers,
    Bojan

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Last Update took my site down’ is closed to new replies.