Support » Plugin: All in One SEO Pack » last update made visual editor error

Viewing 12 replies - 1 through 12 (of 12 total)
  • Yes having the same problem here, it stops the switching from Visual to Text or from Text to Visual.

    Which ever you were in last time it stays in that. Deactivating the plug-in cures it.

    Plug-in updated 19 hours ago so it was the obvious one to look at first.

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @newzdotit I’m not able to reproduce that with just All in One SEO Pack and the Classic Editor (no other active plugins). I’d recommend that you use our troubleshooting steps here to narrow down a plugin conflict – https://semperplugins.com/documentation/how-to-troubleshoot-issues-with-all-in-one-seo-pack/. We’re not able fix something we can’t reproduce so we need to identify the conflict first.

    With the last two update the inverse scene. Now I can see visual mode, and can’t go to text mode. lol

    Plugin Contributor Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Are you able to reproduce the behavior with all other plugins deactivated and the default theme active to rule out a plugin/theme conflict?

    Upgrading to WordPress 5.3 cured the problem without disabling other plug-ins.

    At the time this bug occurred WP5.3 wasn’t offered as an upgrade.

    I just noticed today that I can’t edit one of my draft posts because there are no buttons, all the buttons are not loaded. So I inspect the button bar and I saw bunch of errors in the console. One of them has “aioseop-count-chars” so I think this has something to do with All in One SEO Pack. And after deactivating AIOSEO I can confirm that all the buttons are loaded again, and missing again as soon as I reactivating AIOSEO and refresh the page.

    The relevant error:

    Uncaught TypeError: Cannot read property 'then' of undefined
        at aioseopAddGutenbergEditorListener (aioseop-count-chars.js?ver=3.3.2:7)
        at aioseopAddEventListeners (aioseop-count-chars.js?ver=3.3.2:4)
        at HTMLDocument.<anonymous> (aioseop-count-chars.js?ver=3.3.2:3)
        at i (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,utils&ver=5.3:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,utils&ver=5.3:2)
        at Function.ready (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,utils&ver=5.3:2)
        at HTMLDocument.J (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,utils&ver=5.3:2)
    Plugin Contributor Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    @freeazy
    I really wish that you would create a new post instead of piling onto a different one.

    Follow these steps:
    Disable all plugins other than All in One SEO Pack.
    Update All in One SEO Pack to the latest version (3.3.2).
    Update WordPress to the latest version.
    Switch to the default theme (such as Twenty Nineteen).
    Clear all caching (browser, server, and plugin).

    See if the problem still exists.

    Hi Michael, I posted here because I think my problem is related to this. Not only the tag buttons on the text mode are not loaded, but I also can’t switch to visual mode too. I have cleared all cache on my browser, plugin, and Cloudflare before coming here, and my WordPress and All in One SEO Pack is in the latest version.

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @freeazy are you by any chance using the Gutenberg Editor globally on your website and seeing that error on a Post where it’s not using Gutenberg but the Classic Editor instead?

    @arnaudbroes Nope, I never use the Gutenberg Editor to create a post, I always use Classic Editor in text mode for all posts. I also set the switch editors’ option to ‘no’.

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @freeazy we’d love to take a look at this for you. Please contact us here – https://semperplugins.com/contact/. You can enter the URL of this page where it asks for a license. 🙂

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @newzdotit, @mrphilofaxy, @newzdotit we released an update today that fixed this issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.