Support » Plugin: All in One SEO Pack » super fast support

  • Had some issues with the last update, promptly fixed from the developers! Now I’m going to make a donation 🙂
    Great plugin and support.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    If you turn on debug mode and let me know any WordPress or PHP error that it gives you I’ll take a look.

    What other plugins are you using? What is your theme?

    Hi, I really appreciate your plugin and I do not intend do degrade your work. I can’t put my blog on debug mode right now, but I will try to figure it out later. My Theme is Pluto, by Osetin.
    The error log file says:

    [Thu Mar 03 11:02:57 2016] [warn] [client 93.44.91.117] mod_fcgid: stderr: PHP Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/usr/local/sb/include/init.php) is not within the allowed path(s): (/data/vhosts/dottorblog.com:/tmp) in /data/vhosts/dottorblog.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 332, referer: http://www.dottorblog.com/
    [Thu Mar 03 11:02:57 2016] [warn] [client 93.44.91.117] mod_fcgid: stderr: PHP Warning: require_once(/usr/local/sb/include/init.php) [function.require-once]: failed to open stream: Operation not permitted in /data/vhosts/dottorblog.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 332, referer: http://www.dottorblog.com/
    [Thu Mar 03 11:02:57 2016] [warn] [client 93.44.91.117] mod_fcgid: stderr: PHP Fatal error: require_once() [function.require]: Failed opening required ‘init.php’ (include_path=’/usr/local/psa/admin/plib:/usr/local/psa/admin/externals:/usr/local/sb/include:/usr/local/sb/include/PEAR’) in /data/vhosts/dottorblog.com/httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 332, referer: http://www.dottorblog.com/

    Could you add a file to your ‘httpdocs’ directory named ‘phpinfo.php’ with the following contents:
    <?php phpinfo(); ?>

    Then visit ‘http://www.dottorblog.com/phpinfo.php&#8217;, save the results, and post them through http://semperplugins.com/contact/

    We are looking into this and trying to duplicate.

    Thanks!

    Actually, nevermind about the phpinfo — I was able to duplicate the problem. The conditions for this problem were: 1) both the include_path and open_basedir directives are in use in your php.ini config, 2) a conflicting filename is found in an include_path dir (/usr/local/sb/include/init.php, in this case), but 3) that dir is not part of the open_basedir list. (whew!)

    For now, if you want to fix it in the current version of the plugin, edit the all_in_one_seo_pack.php file, and change line 332 to read like so:

    require_once( AIOSEOP_PLUGIN_DIR . '/init.php' );

    A new version with the official fix will be released soon.

    many thanks!

    If you haven’t done it already, please try installing the latest version (2.3.2.3) and let us know if you have any other problems.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘super fast support’ is closed to new replies.