Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Last update causing error ‘The editor has encountered an unexpected error’

  • Resolved adsacomms

    (@adsalibrary)


    Today I executed a few plugin updates on our site. Afterward, when I went to edit a page or post I was getting this error ‘The editor has encountered an unexpected error’. I tried switching on and off a few plugins to clear it. It appears that the GiveWP plugin is causing some sort of conflict and I have had to deactivate it. Has anyone else had a problem?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Casty

    (@casty)

    +1

    Editing any page throws this error.

    TypeError: this.activateMode is not a function
        at https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:53705
        at ut (https://siteurl.com/wp-content/plugins/give/assets/dist/js/gutenberg.js?ver=2.13.0:33:4751)
        at Function.la (https://siteurl.com/wp-content/plugins/give/assets/dist/js/gutenberg.js?ver=2.13.0:33:41030)
        at n._createModes (https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:53665)
        at n.initialize (https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:53074)
        at n.initialize (https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:65674)
        at n.initialize (https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:82558)
        at n.h.View (https://siteurl.com/wp-includes/js/backbone.min.js?ver=1.4.0:2:14140)
        at n.constructor (https://siteurl.com/wp-includes/js/wp-backbone.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:2600)
        at n.constructor (https://siteurl.com/wp-includes/js/media-views.min.js?ver=48f6d7c6dc519ba1ae9f66328fccdec1:2:36836)

    Saw this in case it’s of help: https://wpdevelopment.courses/articles/how-to-fix-activatemode-is-not-a-function-error-in-gutenberg/

    photoMaldives

    (@photomaldives)

    Is this with latest available version ?

    2.13.0 August 19th, 2021
    New: Fresh new UI for managing Stripe accounts

    Plugin Support Matheus Martins

    (@matheusfd)

    Hi @casty and @adsalibrary,

    Glad you reached out.

    We’ve investigated it and we found that you’ve uncovered an edge-case issue with our GiveWP plugin. What is happening is that there are some conflicts between GiveWP’s JavaScript code and the Gutenberg editor.

    I’ve escalated this to our development team so they can work on a fix. You can follow up on the progress of the fix here https://feedback.givewp.com/bug-reports/p/givewp-should-not-break-the-post-edit-screen

    Our feedback site is designed to be the single source for all updates on particular issues. If any movement has happened, it will be displayed there for both the public and our team internally.

    Thanks for using GiveWP! Have a great day.

    +1 This has broken my site’s ability to edit blocks, and also to use the Customizer. I am using the Kadence theme.

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi folks!

    ​We just released 2.13.1 to resolve this issue. Let us know if updating to that does not resolve things!

    Thanks!

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi all,

    ​We just released 2.13.1 to resolve this issue. Let us know if updating to that does not resolve things!

    Thanks!

    Fixed, thanks for your prompt update!

    Thread Starter adsacomms

    (@adsalibrary)

    Yes, 2.13.1 has resolved this issue. Thank you for your prompt assistance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.