Support » Plugin: Fast Velocity Minify » Last update causes error 404 on plugins.php

  • Resolved dragonwolf5589

    (@dragonwolf5589)



    Hi, after I updated this plugin, I cannot access the plugins.php in the admin page, I get page not found and a ton of internal 500 errors. Luckily I use backup plugins that was able to restore it, and now I can access it again.

    Is there any known issues or compatiblilty issues with other plugins that may interfere with this plugin? its been fine until the last update 2 days ago

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raul Peixoto

    (@alignak)

    I don’t think that problem is related to my plugin, since there were no significant changes that could have caused it.

    An error 404 means that your server couldn’t find the plugins.php… did you perhaps update wordpress itself?

    Try to update your other plugins one by one and see how it goes.
    Does it fail, only when you update mine?

    Did you try to delete the plugin and reinstall again (sometimes wordpress updates get corrupted by servers).

    If you get error 500 messages, do you have access to the server logs in order to check exactly where your error is?

    And perhaps you can enable the debug log on wordpress, and see what else might be causing trouble.
    https://codex.wordpress.org/Debugging_in_WordPress

    Unless some other plugin is using some of my function names, there should be no reason for it to happen. You can paste a screenshot of your plugins.

    Also bare in mind, that you can only use one optimization plugin (don’t use several).
    For cache, I recommend W3 Total cache, with the minification disabled.

    hi,

    sorry for delayed reply, I’ve been very busy past couple days.
    I only use W3 total cache anyway as im aware more than one can conflict.

    For some reason it definitely only happened when I updated your plugin, then I had to use updraftplus to restore the plugins from backup to regain access to the page.

    However I deactivated it completely then updated it and it now seems to be fine. It must be an issue with the update being corrupted or issue with the server updating the plugin.

    sadly no errors are showing on cpanel on the server, even though i have had a few internal 500 errors show up when browsing around the site, its not being logged in the errors log (currently contacting the web server about this) as it is completely blank

    either way thanks for your reply and help, i’ll keep in mind about the wordpress debug log if i have any other issues

    Plugin Author Raul Peixoto

    (@alignak)

    Bare in mind, error 500 codes might show either on php logs, or apache / nginx logs (depends on your settings).

    Usually, error 500 will happen if there’s a fatal error on php OR if you run out of memory.

    Even if you don’t have this much memory (it cannot go over the hardware limits), I recommend adding this to your wordpress wp-config.php file:

    define('WP_MEMORY_LIMIT', '768M');
    define('WP_MAX_MEMORY_LIMIT', '768M');

    Also, if you enable the debug log, those white pages “should” print some error.
    However, if your theme or any of your plugins have the code “error_reporting(0)” anywhere, those errors won’t be reported (it’s unlikely with know plugins, but it happens).

    Thanks for reporting back.
    Glad its solved.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Last update causes error 404 on plugins.php’ is closed to new replies.