Support » Plugin: CategoryTinymce » Last update caused fatal errors

  • Resolved zeuspress

    (@zeuspress)


    On both sites this plugin was installed on, the last update caused them to go offline. The error page that appeared instead mentioned this plugin. I deleted it using my hosting account and the sites came right back.

    I was able to signin to the sites, only the public side was unavailable. Should be an easy fix as the changelog only included 1 change. It’s a helpful plugin. Thank you.

    I use the GeneratePress theme.

    • This topic was modified 4 months, 3 weeks ago by zeuspress.
Viewing 3 replies - 1 through 3 (of 3 total)
  • OK, so I istalled the previous version and the same thing happened. Here’s the error:
    Fatal error: Uncaught Error: Call to undefined function is_product_category() in /home4/rstack7/public_html/stateoffloridaliving.com/wp-content/plugins/categorytinymce/categorytinymce.php:660 Stack trace: #0 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/class-wp-hook.php(286): add_ogmeta_tags(”) #1 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/general-template.php(2745): do_action(‘wp_head’) #4 /home4/rstack7/public_html/stateoffloridaliving.com/wp-content/themes/generatepress/header.php(17): wp_head() #5 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/template.php(722): require_once(‘/home4/rstack7/…’) #6 /home4/rstack7/public_html/stateoffloridaliving.com/wp-includes/template.php(671): load_template(‘/home4/rstack7/…’, true) #7 /ho in /home4/rstack7/public_html/stateoffloridaliving.com/wp-content/plugins/categorytinymce/categorytinymce.php on line 660

    Plugin Author kevin heath

    (@ypraise)

    Hi,

    Thanks for the post.

    Have you tried the 3.8.1 latest version? When I released 3.8, I included support for woocommerce categories but forgot to put in a check that woocommerce was installed.

    This meant that there were issues with web sites that did not have woocomerce installed. I see from what you posted above your issue is with undefined function is product_category.

    This was fixed in 3.8.1

    If you are still having problems please let me know

    Thanks
    Kevin

    • This reply was modified 4 months, 3 weeks ago by kevin heath.

    Yes, reinstalled and works great. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.