• Resolved maysi


    My WordPress website is not available anymore. I get the error message:

    “Database Error: Table ‘xxx.wp_gspin_shortcodes’ doesn’t exist”

Viewing 10 replies - 1 through 10 (of 10 total)
  • I have a similar problem.

    Changing line 75 in wp-content/plugins/gs-pinterest-portfolio/includes/Admin.php

    from this:

    array( $this, 'displayMainMenuPage' ),

    to this:

    array( $this, 'displayMainMenuPage' ) 

    (remove trailing comma) fixes the problem.

    Plugin Contributor GS Plugins


    Hi @progpapa

    The new version is released after removing the trailing comma.

    VERSION 1.4.2 [6TH OCT 2021]
    [Removed] : Trailing Comma.

    Hi @maysi
    We are still waiting for your response.
    Can you please delete/rename the plugin using FTP?

    After deleting install again, hope it’ll fix your issue.

    Let us know.


    Thread Starter maysi


    Hi @gsplugins, thanks I already did that, so that the site is not broken anymore.

    Deleting and reinstalling didn’t work.
    There is still this message.
    The exact message (redacted) is this JSON data:

    {“success”:false,”data”:”Database Error: Table ‘db712310875.wp_gspin_shortcodes’ doesn’t exist”}

    I’ll send you the site link on your contact form.

    I waited a couple of days to see if a solution shows up, but nothing since @maysi asked and said he would provide a link to his site.

    I have also, removed and reinstalled, removed the comma, put the comma back and still I get the same error as indicated above.

    All was well until 2 days ago with the update to version 1.4.2.

    Any additional reason what else could be generating this issue?

    Thread Starter maysi


    @newrupe FYI I provided the plugin author access to a staging site & FTP access, where they can debug this issue.
    They told me that my hosting is not allowing to create a table (which I find a bit weird, because until now everything worked always fine with all plugins).

    Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    FYI I provided the plugin author access to a staging site & FTP access, where they can debug this issue.

    FYI @gsplugins is now on moderation watch because of that.

    @gsplugins While I know you have the best of intentions, it’s forum policy that you not ask users for admin or server access. That includes going around the forums to get that access.

    Users on the forums aren’t your customers, they’re your open source collaborators, and requesting that kind of access can put you and them at high risk.

    If they are paying customers (such as people who bought a premium service/product from you) then by all means, direct them to your official customer support system. But in all other cases, you need to help them here on the forums.

    Thankfully are other ways to get information you need:

    You get the idea.

    We know volunteer support is not easy, and this guideline can feel needlessly restrictive. It’s actually there to protect you as much as end users. Should their site be hacked or have any issues after you accessed it, you could be held legally liable for damages. In addition, it’s difficult for end users to know the difference between helpful developers and people with malicious intentions. Because of that, we rely on plugin developers and long-standing volunteers (like you) to help us and uphold this particular guideline.

    When you help users here and in public, you also help the next person with the same problem. They’ll be able to read the debugging and solution and educate themselves. That’s how we get the next generation of developers.

    Moderator Jan Dembowski


    Forum Moderator and Brute Squad

    @samdani This is not a new thing and was addressed with you 3 years ago.


    If you and your co-workers are going to insist on ignoring the forum guidelines then please contact the plugins team and they can explain how you can self-service the removal of your plugin from the WordPress repo.

    Thread Starter maysi


    For anyone else who is interested in the fix: a new database table needs to be created. This is the SQL I needed run in order to create the table:

    You might need to change the table prefix & collate depending on your installation.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Advisor and Activist

    @gsplugins – Even if someone says ‘Here’s access to my site…’ you need to say “NO THANK YOU.” Seriously, if you break their site, they can take legal action against you. That’s not worth the risk.

    @maysi – Please don’t encourage people to log into sites that are not theirs. You got lucky. Next time, you may get a nefarious person who leaves a backdoor in your site. Sadly you have no way to vet random internet people. What if someone was faking being part of this plugin dev team? An ounce of caution here is needed going forward. Sadly the internet is filled with bad people 🙁

    Plugin Contributor GS Plugins


    Hi @ipstenu

    Thanks for the detailed clarification.
    We’ll definitely follow the rules.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Last update breaks site’ is closed to new replies.