Support » Plugin: Kadence WooCommerce Email Designer » Last update (1.5)

  • Your last update (15/04/2022) causes a critical error on the site and the loss of previously created templates.
    I had to downgrade to version 1.4.10 to restore site and templates.
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Sorry to hear that. I can’t recreate an error can you tell me what the error is from your error log?

    I was thinking about this, very little changed with 1.5.0 so there is very little that could create a new error. One thing is that we updated our templates to match woocommerce 5.6+ if you are using a version of Woocommerce that is older then that could create an issue. If you are using an old version of woocommerce I suggest updating.

    Ben

    I had to downgrade to 1.4 too.

    hannah

    (@hannahritner)

    Hi @megordillo,
    What version of WooCommerce are you using? Were you getting errors? If so, what were they?

    Kindly,
    Hannah

    megordillo

    (@megordillo)

    WooCommerce version is 4.9.5.

    The errors I was getting:

    Fatal Error
    Line 125
    Message Uncaught Error: Call to undefined method Automattic\WooCommerce\Admin\Overrides\Order::get_shipping_phone() in /dom30950/wp-content/plugins/kadence-woocommerce-email-designer/templates/woo/emails/email-addresses.php:125 Stack trace: #0 /dom30950/wp-content/plugins/woocommerce/includes/wc-core-functions.php(345): include() #1 /dom30950/wp-content/plugins/woocommerce/includes/class-wc-emails.php(589): wc_get_template('emails/email-ad...', Array) #2 /wordpress-versions/5.8.4/wp-includes/class-wp-hook.php(305): WC_Emails->email_addresses(Object(Automattic\WooCommerce\Admin\Overrides\Order), true, false) #3 /wordpress-versions/5.8.4/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #4 /wordpress-versions/5.8.4/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #5 /dom30950/wp-content/plugins/kadence-woocommerce-email-designer/templates/woo/emails/admin-new-order.php(56): do_action('woocommerce_ema...', Object(Automattic\WooCommerce\Admin\Overrides\Order), true, false, Object(WC_Email_New_
    File /dom30950/wp-content/plugins/kadence-woocommerce-email-designer/templates/woo/emails/email-addresses.php
    Back
    Plugin Author Ben Ritner – Kadence WP

    (@britner)

    Hi @megordillo,

    Thanks for confirming that your issue is because you are using a very old version of Woocommerce.

    If you are not going to update Woocommerce I strongly recommend you not update woocommerce extensions. Current version of woocommerce is 6.3.

    All the best,

    Ben

    anthony82

    (@anthony82)

    Same here! I had to revert to 1.4.10.

    Woocommerce 5.0.3
    WordPress 5.5.9

    Un errore di E_ERROR è stato causato nella linea 125 del file /web/htdocs/www.xxxxxxxx.com/home/wp-content/plugins/kadence-woocommerce-email-designer/templates/woo/emails/email-addresses.php. Messaggio di errore: Uncaught Error: Call to undefined method Automattic\WooCommerce\Admin\Overrides\Order::get_shipping_phone() in /web/htdocs/www.xxxxxxxxxxx.com/home/wp-content/plugins/kadence-woocommerce-email-designer/templates/woo/emails/email-addresses.php:125

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.