• Resolved peq42

    (@peq42)


    I have just recently made a post in my forum, however the forum page shows as if the last post was from a month ago(when I click it however, it does go to the correct, last sent topic).

    I tried clearing cache, on browser, varnish and cloudflare’s, but its the same. I image its caused by the recent wordpress update? I’m unsure.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor codejp3

    (@codejp3)

    Thanks for posting a link to check out.

    I do see what you’re referring to.

    The main forum index shows that the subforum “Website Updates” was last updated 1 month ago.

    When you go to that actual subforum, it shows an update you just posted today.

    That new post explains a bunch of caching and speedup tweaks performed on your site. My hunch is that the forum index not updating has something to do with one or more of those website speedup tweaks. I know you said you’ve tried playing with them/clearing them, but that’s still my hunch and the only “known” thing that has changed on your site recently.

    I can confirm on my test site that Style Pack is compatible with the latest release of WordPress and will be updating compatibility with the next release (any day now after I finalize a few things).

    I do still think the issue is going to be linked to those recent changes….but you can try this:

    Go to WP Admin > Tools > Forums ( /wp-admin/tools.php?page=bbp-repair )

    Run the “Recalculate last activity in each topic and forum” repair action.

    Let’s see if that makes a difference before getting more involved.

    • This reply was modified 11 months, 1 week ago by codejp3. Reason: fixed minor typos
    Thread Starter peq42

    (@peq42)

    that did not fix it unfortunately. But since its such a small issue, I’ll wait for the update and try again after

    Plugin Contributor codejp3

    (@codejp3)

    The update will not address anything related to your issue. It only includes some minor enhancements to shortcodes and BuddyPress integration. The plugin is already compatible with the latest version of WP as-is. I’m just simply updating the plugin readme file to reflect that.

    Like I said, I’m pretty sure your issue has to do with the recent speed-up/caching tweaks you added.

    Put your site in maintenance mode, disable Style Pack, and refresh the forum index and see if it displays the last topic freshness info properly. If so, then there may be a compatibility issue with Style Pack and one of those recent changes you did. If the forum index freshness still shows incorrectly, then your issue has nothing to do with Style Pack.

    Try that and check back here with the results.

    Plugin Contributor codejp3

    (@codejp3)

    A side note – it probably has nothing to do with this issue, but you do have plenty of errors showing on that forum index page in dev tool. Most of them relate to font files not loading. They are incorrectly using (sanitized for security reasons):


    https://peq42.com/path/to/home/directory/on/server/public_html/wp-content/fonts/manrope/

    or

    https://peq42.com/path/to/home/directory/on/server/public_html/wp-content//fonts/manrope/

    when they should be using:

    https://peq42.com/wp-content/fonts/manrope/

    You may have a “wp_content_dir” being used where it should be “wp_content_url” somewhere in your code related to font files.

    Other issues relate to CloudFlare. Probably not causing issues with the forum index freshness, but certainly slowing your site, filling error logs, and not fully/properly utilizing CloudFlare:

    Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://static.cloudflareinsights.com/beacon.min.js/v8b253dfea2ab4077af8c6f58422dfbfd1689876627854. (Reason: CORS request did not succeed). Status code: (null).
    None of the “sha512” hashes in the integrity attribute match the content of the subresource.

    https://community.cloudflare.com/t/beacon-min-js-blocked-by-cors/346833

    https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS/Errors/CORSDidNotSucceed?utm_source=devtools&utm_medium=firefox-cors-errors&utm_campaign=default

    Thread Starter peq42

    (@peq42)

    Thanks for the heads-up on those errors! Apparently after I migrated my website to a new host, some things were left with old links.

    However, as for the main issue, I really doubt it is related to cache. I cleared any minified file, cleared cache generated through the plugin WP-Optimize, cleared the varnish cache AND cloudflare… As for speed-up script, it was a fancy way of saying “I updated to wordpress 6.3” XD

    • This reply was modified 11 months, 1 week ago by peq42.
    Plugin Contributor codejp3

    (@codejp3)

    No problem!

    Try the isolation method I posted above. See if the issue still exists with Style Pack deactivated and get back with the results.

    Thread Starter peq42

    (@peq42)

    oh it appears I made a mistake. I selected the “Recalculate last activity in each topic and forum” but then didnt click “run” just “Bulk action” then apply.

    Its all fixed now. Thanks for the help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Last post 1 month, 1 week ago” when I just posted’ is closed to new replies.