Support » Plugin: W3 Total Cache » Last-Modified header set incorrectly (Advanced Page Cache)

  • Hello,

    I am using the W3 total cache plugin with the Advanced Page Cache (running on Apache 2.2). Every thing works fine except the Browser Cache. The cached pages never return the correct last modified header. They alway return:
    Last-Modified: Thu, 01 Jan 1970 00:00:00 GMT

    With this output the browser doesn’t refresh the local cache and shows old pages.

    What could be the error?

    Thank you for your help.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Last-Modified: Thu, 01 Jan 1970 00:00:00 GMT

    Are you sure that it is returned by this plugin?

    To confirm, try disabling this plugin and see, if this header is still present.

    I am not sure. But if I disable this plugin or visit a wordpress page as a logged user, this header value is not set.

    I have found a workaround. If I set the option “Set expire header” the Last-modified header has still the wrong value “Thu, 01 Jan 1970 00:00:00 GMT” but the browser clears the cache if the expire time is reached.

    Kristian, problem for me too: ( A solution ?

    Hello phoenix13,

    I dind’t find a solution. But as I described above: If I set the option “Set expire header”, then the browser will use this time value to decide whether the cache should be renewed.

    If you find a solution for this, please post it. Thank you!

    Regards

    With WP Super Cache or WP-FFPC, it’s OK.

    My config : Nginx + PHP-FPM ( Memcached and APC installed on VPS)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Last-Modified header set incorrectly (Advanced Page Cache)’ is closed to new replies.