Sucuri Security - Auditing, Malware Scanner and Security Hardening
[resolved] Last Login doesn't work with Multisite (3 posts)

  1. Patrick Johanneson
    Posted 1 year ago #

    Last Login works fine when I log in to the main site in a Multisite network. However, if I log in from a sub-site in the network, Last Login doesn't record my login. Is there a hook (either in WP core or in the Sucuri Security plugin) that will allow me to modify this behaviour?

    I'm running WP 3.9.1 (current stable release) using subdirectory-style Multisite.


  2. Yorman
    Plugin Author

    Posted 1 year ago #

    After multiple tests in six (6) different installations using sub-domains and sub-folders while setting up the network I was not able to reproduce the bug. The last-logins logs (as other dynamic data stored by the plugin) is independent to the site, so if you have a standard installation with two subdomains the logs will be stored like this:


    Checking the code I do not see why the logs could not be stored, unless there are permissions issues to write in these directories, but that does not seems the case. Anyway, the logs for Site 3 will not be displayed nor in the Network dashboard nor in the dashboard of other sites, if this is the case the I will consider this ticket as resolved.

    Let me know if you want to keep this thread opened.

  3. Yorman
    Plugin Author

    Posted 1 year ago #

    Marking this as resolved because I could not reproduce the error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic