Support » Plugin: Easy Testimonials » Large quote graphic showing over testimonial

  • Resolved graphichome

    (@graphichome)


    Just updated the plugin. Using random testimonials on pages of site. After the update the testimonial is now not indented on the left. Since it lost its indenting, the large quote graphic is now over top of the testimonial. I have tried working through various options and themes but it does not change. Any help is greatly appreciated

Viewing 11 replies - 1 through 11 (of 11 total)
  • Having the same issue when viewing my page at http://jayguilloty.com/index.php/kind-words-cool-people/ . Hopefully it’s on the radar for resolution.

    I’m having a different issue. My blockquote graphic is not displaying at all.

    http://www.greensamurai.website/testimonials/

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey everyone!

    From your links, it looks like y’all have various bits of CSS coming from your WordPress theme that is applying to Easy Testimonials.

    @graphichome – without a link I can’t provide further insight, however there were no CSS changes or class structure changes in our recent update. Had you customized the plugin? If you had, that would be overwritten in an upgrade but otherwise I wouldn’t have expected a change.

    For example, @jayguilloty, while I don’t see anything that looks wrong, I do see your styled Testimonials on the page you’ve linked. The styling on those Testimonials is coming from “http://jayguilloty.com/wp-content/themes/bow/style.css?ver=4.7.3”, which I believe is your theme’s style sheet. Also, I think it looks pretty good! Can you clarify the issue you have?

    @mark-scott — it looks like you are just using the Default Theme, which shouldn’t include any big quotes or anything. In fact, it should look like it does on your site. I do see you’ve added some CSS to your site, outside of our plugin, that appears to not be working:

    .testimonial_body {
        background: rgba(0, 0, 0, 0) url("images/blockquote.png") no-repeat scroll 0 0 !important;
        margin: 0 0 2.6rem 5rem;
    }

    However, that isn’t our CSS and I’m not really able to help you with it — the background image appears to not be at the path you have listed in the CSS. To be clear, this is an issue with some 3rd party CSS (ie, not CSS that is from our plugin.)

    All the best,
    Richard

    Thanks so much for the reply! So sorry, I didn’t clarify that it overlaps when visiting that page while viewing on a mobile device. It still might be what you were referring to. Love the plugin, hopefully it’s something that can be altered to resolve. I’m still learning website setup coding. Jay 🙂

    Sorry for not including a link. This is a dev site. I have not updated yet in the live site.

    http://work.firetech.com/contact-us/

    Here is the page in the live site prior to updating the plugin

    http://firetech.com/contact-us/

    I did not customize the code for the plugin.

    • This reply was modified 2 years, 11 months ago by graphichome.

    Test

    Sorry, I typed a reply and it wasn’t submitted properly.

    • This reply was modified 2 years, 11 months ago by Mark Scott.

    Hi @richardgabriel.

    Thanks for responding.

    And thanks for such a useful plugin!

    I am using additional css. It’s in the plugin’s Custom CSS field of the Basic Options section under the Basic Settings tab.

    The css is:

    .testimonial_body {margin: 0 0 26px 50px; margin: 0 0 2.6rem 5.0rem;}

    If I remove the css, the text is no longer indented and there is no spacing between the paragraphs.

    My theme’s blockquote uses the blockquote.png.

    Up until the upgrade, the blockquote.png was being displayed in the space on the left of the text. I didn’t specify this separately for the plugin; I just assumed the plugin uses the themes blockquote.

    Hi @richardgabriel.

    Thanks for responding.

    And thanks for such a useful plugin!

    I’m using css which is added to the plugin’s Custom CSS field of the Basic Options section under the Basic Settings tab.

    The css is:

    .testimonial_body {margin: 0 0 26px 50px; margin: 0 0 2.6rem 5.0rem;}

    If I remove this css, the text is no longer indented and there is no spacing between the paragraphs.

    My theme’s blockquote uses the blockquote.png.

    Up until the upgrade, the blockquote.png was being displayed in the space on the left of the text. I didn’t specify this separately for the plugin; I just assumed the plugin used the theme’s blockquote.

    @richardgabriel

    I’ve made some changes which gives me the result I had before the plugin was upgraded.

    I removed the css from the plugin’s custom css, and I added this to my theme’s css:

    .testimonial_body {margin: 0 0 26px 50px; margin: 0 0 2.6rem 5.0rem;}
    .easy_t_single_testimonial blockquote.easy_testimonial {background: url(images/blockquote.png) no-repeat;}

    Interestingly, this didn’t work properly using the plugin’s custom css.

    And I still don’t understand how the blockquote.png was being displayed before.

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey @mark-scott!

    The reason the blockquote is working when you move the CSS is that you are using a relative path to the image. When the CSS was located in our plugin’s Custom CSS, the relative path was from our plugin’s base file (and so the path was wrong and no image loaded.)

    When you moved the code to your theme’s CSS, the relative path is from your theme’s CSS file and so the image can be found (as the image is from your theme, not our plugin.)

    I have no idea why the image would have worked before — I don’t think it would have. You could have had the image cached and so you thought it was working but it actually wasn’t, or you used to have that CSS in your theme and didn’t realize it. There isn’t any reason for it to have worked before, the way you had it setup.

    Hey @graphichome!

    I see the quote you are talking about. That quote (the red one) is coming from your WordPress theme (the tempera theme, according to my inspector.)

    The following CSS will add back your padding from your theme:

    .easy_t_single_testimonial blockquote.easy_testimonial {
        border: 0 none;
        15px 15px 15px 90px
    }

    @jayguilloty

    The CSS that impacted @graphichome was the following:
    .easy_t_single_testimonial blockquote.easy_testimonial {
    border: 0 none;
    padding: 10px;
    }

    Specifically, the 10px of padding changed (previously it was set on a lower target.) So, you could try altering that padding using our plugin’s Custom CSS and see if that returns things to what you desire.

    I hope this helps you all!

    Best,
    Richard

    Thanks @richardgabriel.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Large quote graphic showing over testimonial’ is closed to new replies.