Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author M Asif Rahman

    (@asif2bd)

    Let me answer one by one.
    1) You have Yoast SEO plugin installed and Twitter Cards support active in there, so from your source code I do see you have 2 card setting setup, and it will confuse twitter. You have to turn off Twitter Cards feature from SEO plugin.

    2) Look at the official resource, it says 280px in width, and at least 150px in height is the minimum.

    3) To configure custom field, go to “Twitter Cards Meta Option”, Select “From a custom field” from the “Image Selection:” and in the below field put you custom field name. Take a look at the screen shot from this link.

    4) And you can’t test multiple setting on a single post, as Twitter Cache first request, and take very long to purge that cache, so if you are updating image or setting for a single already published image, you will not see any changes in validator or even when you link image. You have to make a new post with the setting or image you want. This is how Twitter works.

    Thank you for your quick answer. I did not know that I had Yoast Twitter Card support turned on, so I’ve turned that off. As for the size, I think the images really need to be 2:1 in order not to get cropped. 280×150 or any multiple of that leads to a little bit of cropping. I can’t confirm that 100% until I make a new post, but I do know that 280×150 will be cropped.

    The major piece that I was missing was what to do with the custom field information on each post. I had it set up correctly in the Twitter Card option, but I could not figure out what the next step was – how to indicate which picture to use in each post. I finally put it all together.

    For anyone else who can’t figure it out: Upload the image that you want to use to your post. You don’t have to place it in your post, you just have to upload it and get its URL.

    If the Custom Fields editor is not showing for you in the WordPress editor (it wasn’t for me), you’ll have to go to “Screen Options” in the top right corner and add it. Click “Enter New” under “Name.” Then, put “images” (or whatever word you set up in the Twitter Card options) in the “Name” field, and put the URL of the image in the “Value” field. Add the custom field, then update or save your post, and the correct image should show on Twitter.

    Plugin Author M Asif Rahman

    (@asif2bd)

    Actually a lot of themes and site use custom field image, in that case you have an image already in custom field already, its actually was not created as a way to manually change image per post. Maybe in future update we could add an option to manually input image per post. Don’t you have image in every post? Why you need to manually add image in each post?

    And the aspect ratio should not be a big issue, keep in mind Twitter shows the image in different size in different scope, like in main site or under mobile app. If its a rectangular image it should look ok, should not be a big deal. And I dont think any more post image with a post smaller than that site.

    Thank you for your response. I have many images in my posts, but I want to either choose which one I’m using, or use one that isn’t in my post. And for the ones that have borders, cropping makes them look bad. Here’s an example of an image I’ve made especially for sharing on Twitter. Since it has a border, cropping could have looked much worse (luckily it wasn’t bad–looked worse in the authenticator–but I would like to use the correct size in the future).

    Plugin Author M Asif Rahman

    (@asif2bd)

    Ok, But this is probably one of the most beautiful looking tweet with Large Summary Card I have ever seen, honestly. If you permit I would like to feature it on Twitter Cards Meta.

    Thanks! As long as there’s some kind of link or credit, either to my blog (SelfishMom.com) or to my twitter account (@AmyOztan), go for it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Large Image Being Cropped’ is closed to new replies.