Support » Plugin: Admin Columns » Languages icons not displayed

  • Resolved artyus

    (@artyus)


    Hey!

    When updating to version 4.3, the languages icons in the heading of lists are stop showing. This also affects the usual pages and lists of goods (WooCommerce).

    Screenshots.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Stefan van den Dungen Gronovius

    (@dungengronovius)

    Can you tell me which plugin you’re using to display the languages?
    I suspect you’re using a translation plugin to do that.

    Thread Starter artyus

    (@artyus)

    Polylang.

    For Woocommerce integration — Hyyan WooCommerce Polylang Integration.

    Never before have there been such problems.

    Plugin Contributor Stefan van den Dungen Gronovius

    (@dungengronovius)

    Thanks for the information. I was able to reproduce the issue and created a fix for the next release. If you want to change it in the meantime you can change the following file:

    /admin-columns/classes/Settings/Columns/Label.php

    Change the method set_label to:

    public function set_label( $label ) {
    	$this->label = apply_filters( 'ac/column/label', wp_kses( $label, true, array_merge( wp_allowed_protocols(), [ 'data' ] ) ), $label );
    }

    We sanitized the stored label for security reasons but did also sanitize base64 images during the process. This should fix the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Languages icons not displayed’ is closed to new replies.