Support » Plugin: Polylang » Language without translation in draft

  • Hello, I prepared a translation of a language, but I did not publish the page. (in draft)

    I added language switcher to the menu and checked the “Hides languages with no translation” option. However, when I check the site, the language switcher still shows the draft language with no translation. When I click it, it redirects to the error page.

    • This topic was modified 4 months, 1 week ago by birblogcu.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chouby

    (@chouby)

    Hello,

    I am not able to reproduce on my test install:
    – WP 6.1 + Twenty Twenty One + Polylang 3.2.5.
    – Language switcher in menu: Displays language names and Hides languages with no translation.

    The translated draft doesn’t appear in the language switcher. I suggest to check for a conflict with your theme or other plugins.

    • This reply was modified 4 months, 1 week ago by Chouby. Reason: typo
    Thread Starter birblogcu

    (@birblogcu)

    Thank you for your reply.

    In fact, an error occurred when I translated the page I published the translation into a draft. So the page was live before. My goal is to temporarily disable the use of a language.

    However, now when I try to access the page in the draft, it appears in the language switcher menu, but I am redirected to the error page. So normally it needs to redirect to the native language.

    I checked the plugins but couldn’t find anything to conflict with.

    I use this; WP 6.1 + Twenty Twenty + Polylang 3.2.5.

    • This reply was modified 4 months, 1 week ago by birblogcu.
    • This reply was modified 4 months, 1 week ago by birblogcu.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.