WordPress.org

Forums

Weekly Class Schedule
[resolved] Language support - polish "ąęśćżł.." are changed to "?" (5 posts)

  1. smarta
    Member
    Posted 1 year ago #

    every time when I am adding to wc schedule (class, instructor, classroom, notes) a text that uses typical polish letters - like "ąęśćżł.." - those letters are changed to "?" sign. As a result on my website wc schedule unfortunately also shows texts with "?" in the middle of a word.

    Is there any fix I can use? Or could you please add some language support and make wc schedule understands non english letters as well.

    http://wordpress.org/plugins/weekly-class-schedule/

  2. ibab
    Member
    Posted 1 year ago #

    How did you even change the language? I made .po and .mo files of the .pot file but can't seem to find anywhere a setting that would affect to the language file that is being used.

    But I think your issue is just generally charset related. Is your WordPress installation in Polish or English? If it's English, you need to probably change the charset to something else. Not sure where you can do this though.

  3. smarta
    Member
    Posted 1 year ago #

    I have installed the english version of wordpress and then changed one setting in wp-config.php file:
    define('WPLANG', 'pl_PL');
    as a result I have most of the wordpress menu in polish.

    In wordpress admin's inputs and textfields I'm using all letters ("ąęśćżł..." also) and everything works well. Even in other plugins (where I get labels in english, so I assume they do not have any special polish version :) ) it all works well.

    The only problem I have is in Weekly Class Schedule plugin. In all inputs/textfields in this plugin, when I use those non-english characters and save changes, I get all those characters changed to "?".

    It's possible that there is some charset mismatch.. (but where?... and how to change it?..) .. Maybe it's during saving to database? Maybe fields have some setting to accept only Latin characters and ignore Latin Extended? ....

  4. smarta
    Member
    Posted 1 year ago #

    ...oh, and I checked that in wp-config.php file I have database charset set to utf8 (it was default setting)
    define('DB_CHARSET', 'utf8');

  5. smarta
    Member
    Posted 1 year ago #

    in wcs3 there is no more problem I wrote about :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Weekly Class Schedule
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags