Support » Plugin: Mongoose Page Plugin » Language setting: Site Language not working

  • Resolved tom3r

    (@tom3r)


    Hi!

    When the language setting is set to default (Site Language) the plugin remains in english, although my wordpress installation is in a different language. Is there a way to fix this, or I have to specify the language in the code that I need?

    Thanks in advance !

Viewing 11 replies - 1 through 11 (of 11 total)
  • tom3r

    (@tom3r)

    Actually, setting the language in the shortcode did not change the language in the front end. Any suggestions?

    tom3r

    (@tom3r)

    Actually, setting the language in the shortcode did not change the language in the front end. Any suggestions?

    Plugin Author Cameron Jones

    (@cameronjonesweb)

    Hi @tom3r,

    This is usually caused by another Facebook plugin already initialising the SDK in a different language, do you have any other Facebook plugins on your site?

    Thanks,
    Cameron

    tom3r

    (@tom3r)

    Hi Cameron,

    No, this is the only facebook plugin on my site.

    Plugin Author Cameron Jones

    (@cameronjonesweb)

    No worries, would you be able to share your website URL?

    tom3r

    (@tom3r)

    Sure. You may check it on this page on the widget area: https://rudraksha.hu/szolgaltatasok/rudraksha-ajanlas/

    Here the language changes when I change it within the widget.

    On this page: https://rudraksha.hu/kapcsolat/ I have the code inserted from the generator, and this one does not react to any language change.

    Thanks Cameron

    tom3r

    (@tom3r)

    Hi,

    Still couldn’t find the fix for this problem. Any suggestions?

    Plugin Author Cameron Jones

    (@cameronjonesweb)

    Hi @tom3r,

    I haven’t been able to get to the bottom of the issue with your site as yet, would be able to share a full site backup with me so I can take a look further and try to find the issue?

    Thanks

    tom3r

    (@tom3r)

    Hi Cameron,

    I think I am not able to do that right now. Is there any other way we can find the issue? I have English language installed on my wordpress admin, but the selected language of my site is hungarian and the admin panel is in that language. I am using a child theme, if that might be important to know.

    What do you suggest?

    Plugin Author Cameron Jones

    (@cameronjonesweb)

    Hi @tom3r,

    I think I’ve found the issue. I think the generator is giving out the wrong key for the language. If you could try adding language="hu_HU" to your shortcode and let me know if that works.

    Thanks

    tom3r

    (@tom3r)

    Yes, the shortcode contained lang="hu_HU" which didn’t work. Now it is good. The widget is working if I set the language there.

    This is resolved now, but it would be great in the future to fix the issue when “Default (Site language)” is selected.

    Thank you so much for your help.

    Best wishes to you

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Language setting: Site Language not working’ is closed to new replies.