Support » Plugin: Google Forms » Language on form text

  • Hello Good People,

    I have embedded a form on one of my pages of my wordpress site. The form works and all of the text within the form is in english but somehow the autogenerated text such as the word “required” at the top and the send button have been switched to german. I have tried making a new for and re-embedding it but the problem persists so its seems like it is a wordpress issue rather than an google issue.

    Any suggestions?

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    It is unlikely this is a WordPress issue as that text is generated by Google and used by the plugin as received UNLESS you use the override features which are available on the Advanced Tab of the plugin settings.

    More than likely you are running into an issue where Google, trying to be helpful, has determined that your web server, which actually makes the request to Google for the form’s HTML, is in Germany or another country Google believes should default to German.

    Google Drive/Docs/Forms supports overriding the language by appending the &hl=XX to your Google Forms URL where XX is the language code you want Google to use. You can see an example of this on my web site here.

    Thanks so much for your reply. I cannot seem to find the &hl=XX code in the URL for my form. Could you give me a better idea of where to add/modify this?

    Thanks again.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    The language parameter won’t be there unless you add it manually. That is what the post on my web site describes. When you enter the URL in WordPress, you’ll need to append the hl=XX (where XX is your language code – e.g. hl=&fr is what you would use for French, each language is different).

    Right however I do not see an hl=XX code in my URL.

    Here is code for what I have in wordpress for this form:

    [gform form=’https://docs.google.com/forms/d/e/1FAIpQLScbepOASbakXm3WyDA5ODCe2ZGDItk8byFsBczHGgr8Vh1Yrw/viewform’]

    Where would I find or add the hl=&en into the URL?

    Thanks again.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Yikes – you are using the old short code which was deprecated 3-4 years ago. You need to define the form using the Google Forms Dashboard menu and then use the “wpgform” short code to put it on a page or post.

    That is as much as I can respond with my phone, I’ll add more when I get home.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Using your URL as an exmaple, if I wanted my Google buttons in French, I would define the form in WordPress using this URL:

    https://docs.google.com/forms/d/e/1FAIpQLScbepOASbakXm3WyDA5ODCe2ZGDItk8byFsBczHGgr8Vh1Yrw/viewform?hl=fr

    Note the “?hl=fr” on the end of the URL – this is the language parameter which Google uses to localize some (but not all) of the text on the form. If you simply copy and paste the URL above into your browser (warning – you may need to run in “incognito” mode if you login to Chrome otherwise Google will override the language parameter with your personal setting or what Google thinks you should see).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.