Support » Plugin: qTranslate X » Language Not Display Whne Upload To Server

  • Resolved Himansu

    (@devhimanshu)


    I use two language Arabic and English in my website using this plugin but when i transfer to live website than instead of Arabic it’s display like ‘???’ for all content and title.

    I check database all content perfect as local like “[:en]All Tools[:ar]أدوات[:]” but not display in fronted even if admin panel.

    I fetch same issue for Arabic in previous version of wordpress also.

    https://wordpress.org/plugins/qtranslate-x/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Gunu

    (@grafcom)

    @himansu

    check Settings – Languages – Languages
    The Arabic language has been activated?
    Settings – Languages – Advanced – Update Gettext Databases
    check Update Gettext databases now.

    I solve that.It’s because of Unicode-8.
    I create new plugin and create languages file in that plugin.

    When i add $locale='ar'; in config file than translation display but when i change arabic language using qTranslate X language chooser than new plugin translation not working.
    Help me for that.

    Plugin Author Gunu

    (@grafcom)

    Look here for integration of plugins Integration Guide

    I read installation in customization document also see demo json file that attach in documents.
    I create new plugin named ‘grbrains’ and i create new i18n-config.json file in ‘i18n-config\plugins\grbrains’ folder and call that file in Configuration Files integration in WordPress admin panel.
    JSON file code as below.

    {"vendor":{"plugins/grbrains":"1.0"},
    "admin-config": {
    "widgets":{
    	"pages":{"widgets.php":""},
    	"forms":{
    		"widgets-right":{
    			"fields":{
    				"widget-content":{}
    			}
    		}
    	},
    },
    "options-general":{
    	"preg_delimiter":"#",
    	"pages":{"options-general.php":"^(?!.*page=[^=&]+).*$"},
    	"forms":{
    		"options":{
    			"fields":{
    				"admin_email":{},
    			}
    		}
    	}
    }
    }
    }

    But it’s not working i made same change in root json file but not apply any changes.
    When i do changes in new plugin pages that it’s working fine.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Language Not Display Whne Upload To Server’ is closed to new replies.