Support » Plugin: Polylang » Language locale issue on the homepage

  • Hi guys,

    I’m having an issue with language switching on the homepage

    Default language = English, RUS/UKR implemented as /ru/pagename_ru

    When the user opens the site in non-English browser locale they can’t switch to English, but can switch between RUS/UKR

    After multiple experiments, I found the workaround – do disable Hide URL language information for default language feature, but this adds ugly /en/home to the URL
    https://prnt.sc/18sl8wl

    Any ideas on root cause and how to fix it?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter igor4wp

    (@igor4wp)

    @chouby is it something you can help with?

    Yes! I have the same problem. And the same conclusion too. In Languages => Settings => URL Changes. If I uncheck the box: “Hide language information in the default language URL”, there is no more problem of redirection when clicking on the link of the home page of the menu.

    For me, the problem occurs when I try to access my home page in French (default language) I am automatically redirected to the English one OR the 404 page.

    Could you please help us?

    Thread Starter igor4wp

    (@igor4wp)

    It would be great if @chouby could find a minute to reply to us!

    Thread Starter igor4wp

    (@igor4wp)

    @acyian

    please check on your site – looks like a recent update has fixed the issue and we can enable Hide URL language information for default language feature

    a quick check on my site seems to be ok

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Language locale issue on the homepage’ is closed to new replies.