Support » Plugin: Media Library Assistant » Language is not changing

  • Resolved Atta Ur Rehman

    (@atta-ur-rehman)


    Hey I have multilingual site. Eng And Dutch. I activated the plugin and it automatically translated to dutch of Netherlands. Now my backend (Admin Panel) is in english but this plugin is showing all its settings in dutch.

    Please guide me about this issue. Is there any setting of languages in this plugin.????

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your question. You don’t say what plugin or other method you are using to give your site multi-lingual capabilities, so I can’t give you a specific answer.

    MLA does not have any language-specific settings. It respects the WordPress handling of languages and it does have specific support for Polylang and WPML, two of the more popular multi-lingual plugins.

    I am not sure what you meant when you wrote “this plugin is showing all its settings in dutch.” Can you give me some additional details?

    I am traveling until June 20 and will not have Internet access until I return home. Thanks for any additional information you can provide, for you patience and for your interest in the pluighin.

    Hey David, Thanks for the reply.

    I sorry for disturbance in your busy schedule.

    Actually I am using WP-Mulitlang https://wordpress.org/plugins/wp-multilang/

    Before that I tired to used polylang but it did not suites my requirements.

    When I install any plugin wp-multiling auto translate that plugin.

    So MLA is also translated in dutch(I am using ENG AND DUTCH).

    BUT like other plugins MLA is always showing in dutch language although my back end is in english and all other admin interface is in english too.

    If will let you check my backend setting. Please send me email.

    Hey David. I want to ask one more question?

    Can we add custom taxonomy admin columns in Media -> Assistant screen. And then show taxonomy terms in BULK EDIT option?

    Kind Regards.

    Plugin Author David Lingren

    (@dglingren)

    Thanks for an interesting question and for your patience in awaiting my response.

    I have researched this issue and I believe it is a WordPress problem which I have not found a way to avoid. WordPress loads the DUTCH language file before the plugin can get control and stop it. WordPress does not appear to handle the ENGLISH case because MLA is written in ENGLISH and there is no “translation” file for the native language.

    I will ask the WordPress team if there is a fix but I am not optimistic. In the interim, you can avoid the problem by renaming the /wp-content/languages/plugins/media-library-assistant-nl_NL.mo/ file to something like xmedia-library-assistant-nl_NL.mo, which WordPress will ignore and load the default ENGLISH language strings.

    I will leave this topic unresolved for now. Please let me know if you try the workaround and if it works for you. Thanks for your understanding and for your interest in the plugin.

    Plugin Author David Lingren

    (@dglingren)

    You wrote “Can we add custom taxonomy admin columns in Media -> Assistant screen. And then show taxonomy terms in BULK EDIT option?

    You can add MLA support for any custom taxonomy by navigating to the Settings/Media Library Assistant General tab and scrolling down to the “Taxonomy Support” section. Check the “Support” and “Inline Edit” boxes for the taxonomy you want to add, then scroll to the bottom and click “Save Changes” to record your new settings.

    Let me know of you have any problems or further questions about the above suggestions.

    Plugin Author David Lingren

    (@dglingren)

    I have done some more work and I believe I have found a fix for the issue you’ve reported. I have uploaded a new MLA Development Version dated 20190625 that contains the fix. You can find step-by-step instructions for using the Development Version in this earlier topic:

    PHP Warning on media upload with Polylang

    It would be great if you can install the Development Version and see if it works for your site. I will leave this topic unresolved until I hear back from you.

    Plugin Author David Lingren

    (@dglingren)

    I have released MLA version 2.80, which includes the updates required for this topic.

    I am marking the topic resolved, but please update it if you are still having trouble after updating to the newest MLA version. Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.