WordPress.org

Forums

Circumference Lite
Language, favicon (4 posts)

  1. haije
    Member
    Posted 1 year ago #

    Hi,

    thanks for a great theme!

    Two questions:

    1) language files. I have translated the language files. I am using a child theme of yours. It seems to be, that if I put the language files (like "de_de.po, de_de.mo") in to the child theme's languages-folder, they do not work. So I have to put them in to your original themes languages-folder, and then the translation works.

    Problem: when I update the "mother" theme of yours, the language files disappear. Do I always have to copy the language files again to the mother theme? Or how do I get them to work in the Child theme?

    2) Favicon. I made a favicon but I cannot manage to make it show up. It is in the root folder and in the child themes main folder.

    I also edited the header.php file adding these in the head-section:
    <link rel="shortcut icon" href="http://domain.com/favicon.ico" type="image/vnd.microsoft.icon"/>
    <link rel="icon" href="http://domain.com/favicon.ico" type="image/x-ico"/>

    How do I get the favicon to work?

    Thanks in advance!

  2. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    Strange, it should not be disappearing. What happens when you update the parent theme (Circumference Lite), the existing theme files get overwritten. The language file for your translation should not be affected. I would recommend checking the WordPress translation section in their codex to ensure you did not miss anything. However, if you are doing everything as required but you are still losing your file, post this issue in the WordPress forums and see if anyone experiences this as well and for any solution. I just did a quick look on Google and it appears other people have experienced this as well in the past.

    For the favicon, check the codex for this: Favicon

    As a side note, I would ensure you always keep a regular backup of your file(s).

  3. haije
    Member
    Posted 1 year ago #

    Hi,
    thanks for your answer.

    I'll have to ask about the theme update and deleted files somewhere else.

    The favicon thing was my mistake... Solved.

  4. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    If you find out a solution about updating deleting your language files, post a follow up here because I'm curious.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic