WordPress.org

Forums

Contact Form by BestWebSoft
[resolved] Language (4 posts)

  1. egilarntzen
    Member
    Posted 1 year ago #

    Hey.

    I can't get this contact form to display Norwegian text. It works in English, but when I change to Norwegian the labels and text disappears.

    My site is http://www.tomrerdahl.no.
    Go to "Kontakt".

    I have set my Wp-config.php to:

    define('WPLANG', 'nb_NO');

    And I also use this code to display my contact form:

    <?php echo do_shortcode('[contact_form lang=nb_NO]'); ?>

    There is a language folder in the contact form folder, and a file there is called: "contact_form-nb_NO.mo".

    http://wordpress.org/plugins/contact-form-plugin/

  2. bestwebsoft
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    1)How to add the contact form not in English?

    Add a language in the block "Language settings for the field names in the form" on the plugin settings page.

    Mark the check box (if it's not marked yet) in the block "Change the names of the contact form fields and error messages", choose the necessary tab and fill in the fields. Choose the necessary tab in the block "Action after email is sent" as well and fill in the field. Save the changes.

    You will see the shortcode under the tab with the necessary language. Please paste that shortcode to the page or post.

    2) It is not clear enough where exactly you add this line. Into some file? Why don't you use the standard method of adding a shortcode?

    <?php echo do_shortcode('[contact_form lang=nb_NO]'); ?>

    Sincerely,
    Support Team

  3. LasseNielsen
    Member
    Posted 1 year ago #

    Hey

    I cant get it translated to Danish (da_DK)

    On my page type:

    [contact_form lang=da_DK]

    And i have checked that they are in the language root.

    I have also changed config to:

    define('WPLANG', 'da_DK');

    All the fields are left empty when i am trying to change to it, can you help me here ?

    Thanks.

  4. bestwebsoft
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lasse,

    How to add the contact form not in English?

    Add a language in the block "Language settings for the field names in the form" on the plugin settings page.

    Mark the check box (if it's not marked yet) in the block "Change the names of the contact form fields and error messages", choose the necessary tab and fill in the fields. Choose the necessary tab in the block "Action after email is sent" as well and fill in the field. Save the changes.

    You will see the shortcode under the tab with the necessary language. Please paste that shortcode to the page or post.

    Sincerely,
    Support Team

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form by BestWebSoft
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic