Support » Themes and Templates » Landing Page Being Listed as a Menu Item

  • I have created a landing page for my blog and also have created a page called “Home,” where I want people to go after they have visited my landing page for the first time. The problem is that I have TWO pages called “Home” on my site now; one is the page I created called “Home” and the other is the Landing Page.

    Is there a way I can remove the Landing Page from the Menu?

    My site is http://sandrawintermusic.com

    Thanks in advance for your help.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Have you tried to override this by going to Appearances > Menu and create a custom menu and add whatever you want or delete it from your current menu?

    Hi Salsaturation:

    I don’t see a way to delete it in the Appearances-Menu area. Frankly, I haven’t figured out how that section is even supposed to work yet. Guess I should look for KB posts on that. 🙂

    You know a menu is different from a page right? A menu if for if you add a menu to your website, I have never even used a menu.

    Hi Adrian,
    Now that you mention it, I realize I said “menu” but I meant page. The Landing Page is showing along with the other pages (About Me, Home, Blog, etc.) and I can’t figure out how to NOT have it show.
    Thanks for the clarification.

    Is creating a landing page an option in your theme? Or do you have the default home page that you renamed to landing page and then you also have a new page that you named home?

    And if you removed landing page would your landing page not be gone? Or is this different from your landing page? And you wan’t to remove the landing page from you menu that list all your pages?

    Hi Adrian,
    No, it’s not an option. I did as you had guessed: used the default home page to create a landing page and then created a separate page called home.
    I do want to hide the landing page on the “menu” that lists my pages. IOW, I don’t want it listed with the other pages. Make sense?
    Sandra

    Oh sorry I can be pretty stupid sometimes, I thought you were talking about the back end. There should be a place to add a little custom CSS. Add this. It hides the first list element of the menu.

    #site-navigation > div > ul > li:first-child {
    display: none;
    }

    You can consider making a child theme do add css, its actualy pretty easy if you follow the instructions exactly. https://codex.wordpress.org/Child_Themes
    But if this is your only change no real need.

    Now you can change the page order to get the real home over to the left. (Make it page 1 or higher though, not page 0, as page 0 is being hidden)

    Another little CSS goody if you want.

    #site-navigation > div > ul > .current_page_item {
    pointer-events: none;
    }

    Will make it so that you cannot click on the menu button for the page you are already on.

    Thanks so much, Adrian. You’re a smart lady. I just wasn’t clear at first.
    Will let you know how it goes when I’ve had a chance to try out the CSS script. Gotta fly right now.

    No problem. Don’t feel bad about it, it is a unisex name, but I’m not a lady. I should probaly upload my picture anyways, this default avatar is pretty scary.

    Oh my! So sorry! I shouldn’t have assumed. I apologize.

    Anyway, I would love to insert the code but I am a little uncertain where it should go. I’m assuming I would be editing the style.css page, yes?

    I’m wondering if it should go in this area:

    ********************************

    /* Navigation Menu */
    .main-navigation {
    margin-top: 24px;
    margin-top: 1.714285714rem;
    text-align: center;
    }
    .main-navigation li {
    margin-top: 24px;
    margin-top: 1.714285714rem;
    font-size: 12px;
    font-size: 0.857142857rem;
    line-height: 1.42857143;
    }
    .main-navigation a {
    color: #5e5e5e;
    }
    .main-navigation a:hover {
    color: #21759b;

    .main-navigation ul.nav-menu,
    .main-navigation div.nav-menu > ul {
    display: none;

    .main-navigation ul.nav-menu.toggled-on,
    .menu-toggle {
    display: inline-block;

    ************************************************

    Near where it says

    .main-navigation ul.nav-menu
    .main-navigation div.nav-manu > ul {
    display: none;

    Is that where to insert the code you gave me?

    again, my site is sandrawinter.com/home

    Sorry to be a bother. Just not sure where to insert the code.

    Thank you again.

    No don’t edit the existing theme, it will be overwritten when the theme updates and your website will break without warning.

    Best practice is to make a child theme, follow theae steps and your child theme willl appear in your theams and you can select that, it will be exactly the same as the parent theme only wtih your overwriting stylsheet applied. https://codex.wordpress.org/Child_Themes Make sure to have good attention to detail when following the instructions though or it wont work.

    Alternatively there are sometimes built in spots in the dashbord were you can put custome CSS. But child themes are pretty slick, allow you to do more advanced stuff later, and make your style sheet more modular

    Hi Adrian,

    Okay. I have created the child theme and activated it. Also put in the code. The child theme works, but the code is not helping with the original problem.

    Here’s how I put the code in on the child theme:

    **********************************
    /*
    Theme Name: Twenty Twelve Child
    Theme URI: http://sandrawintermusic.com/wp-content/themes/twentytwelve-child
    Author: the WordPress team
    Author URI: http://wordpress.org/
    Template: twentytwelve
    Description: The 2012 theme for WordPress is a fully responsive theme that looks great on any device. Features include a front page template with its own widgets, an optional display font, styling for post formats on both index and single views, and an optional no-sidebar page template. Make it yours with a custom menu, header image, and background.
    Version: 1.3
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: light, gray, white, one-column, two-columns, right-sidebar, fluid-layout, responsive-layout, custom-background, custom-header, custom-menu, editor-style, featured-images, flexible-header, full-width-template, microformats, post-formats, rtl-language-support, sticky-post, theme-options, translation-ready
    Text Domain: twentytwelve-child

    This theme, like WordPress, is licensed under the GPL.
    Use it to make something cool, have fun, and share what you’ve learned with others.
    */

    @import url(“../twentytwelve/style.css”);

    /* =Theme customization starts here
    ————————————————————– */
    #site-navigation > div > ul > li:first-child {
    display: none;
    }

    ********************************

    Did I put it in wrong? Why isn’t it working?

    The style sheet does not appear in your header in chrome developer tool (witch by the way are you using that thing? its great)

    Did you go into themes in your admin panel and change to your child theme? I forgot to do that last week and spent a whole day in tears.

    Hi Adrian,
    Yes, I changed the theme to the child theme and just double-checked it. It is active. If you’re looking at the landing page, that has a different theme than the rest of the site. (Just LOVE my jonradio Multiple Themes Plug-in!)
    What’s next?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Landing Page Being Listed as a Menu Item’ is closed to new replies.