Support » Plugin: Booking Calendar » Labels width and hight

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author wpdevelop

    (@wpdevelop)

    Hello,
    Please send the link to the page with booking form, so then I will try to help you.

    Hi, the website is not ready yet … it’s not online … is there any other way I can send you a screenshot of the page?
    Thanks

    PS: As I wrote the website is not ready yet, but I put it online for a while just for you to check on it … it’s the fastest way 🙂

    http://www.imbianchinomilanoeprovincia.it/preventivo-online/

    I’d like the white labels to be shorter and the fields more centered in the page.

    Thanks for your help!

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello,
    but at this page there is no the form fields, just the calendar. So I can make only suggestions about your issue.

    If you are want to make the days cells in the calendar smaller, please include the booking shortcode (which you ar inserted into that page) into this div, its will reduce the size of calendar

    <div class="widget_wpdev_booking"> ... some booking shortcode ... </div>

    Also you can make the additional CSS customization at the ../booking/css/client.css file.

    According setting the fields centered, please open the Booking > Settings > Fields page
    and insert all booking form fields into these DIV:

    <div style="text-align: center;">
    ... YOUR BOOKING FORM FIELDS CUSTOMIZATION...
    </div>

    You can also add other CSS styled to that DIV element, like padding or margin.

    http://www.imbianchinomilanoeprovincia.it/preventivo-online/

    Hi thanks for your quick reply! If you click on the “Avanti” link (bottom left of calendar) you go to the other section where the booking form fields are…

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    1) I can not click on that link, because its overlay by some other HTML elements. For fixing this issue, pelase make this modifications in the Booking > Settings > Fields page
    from this code:
    <a href="javascript:bk_calendar_step_click();">Avanti</a>
    to this code:
    <a href="javascript:bk_calendar_step_click();" style="z-index: 2147483647; position: relative;">Avanti</a>

    2) then please open this file http://www.imbianchinomilanoeprovincia.it/wp-content/plugins/booking.bs.4.0.2/css/client.css

    and add to the bottom of this file this code:

    .bk_form_step {
    margin:0px 20px auto !important;
    text-align:right;
    }
    
    .bk_form_step p{
    padding-bottom:5px;
    }
    .bk_form_step input{
    width:180px;
    height:16px;
    }

    In the same way you can make other CSS customization.
    Please note, if you will modify the source code of the Booking Calendar, we will not guaranteed the correct work of plugin and do not support it.

    Sorry, I am not that smart when it comes to .html or .php laguages. So, since I do not want to mess things up, I have changed the form layout to

    What if I wanted the booking form fields (two columns) to appear right next to the calendar?

    Thanks again

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    If you want to have the calendar and the booking form fields in the 2 columns.
    You can customize the look of the booking form at the client side at the Booking > Settings > Fields page.
    So for having the calendar at the left side and booking form at the right side you are need to have the configuration similar to this:

    <div style="float:left;margin-right:10px" > [calendar] </div>
    <div style="float:left;margin-right:10px" >
    ... OTHER FORM FIELDS CONFIGURATIONS...
    </div>

    Sorry to bother you again with this but this is driving me crazy!
    I can’t get to fix it! … The configuration you indicated (that I had already tried before) it’s for the two columns (calendar + booking form).

    I do need the booking form to be on 2 columns right next to the calendar (that’s why I was asking you how to reduce the labels width). So the total is 3 columns (calendar – form fields – form fields) : see the page (I was able to get it on 3 columns but they overflow the page )

    I actually need the booking form to be on 2 columns right next to the calendar (that’s why I was asking you how to reduce the labels width). Please see the page (I was able to get it but they are way to big)

    Thanks

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello,
    Please open this file http://www.imbianchinomilanoeprovincia.it/wp-content/plugins/booking.bs.4.0.2/css/client.css

    and add to the bottom of that file this code:

    .booking_form input {
     width:180px;
    }
    .booking_form p {
     padding-bottom: 5px;
    }

    Also at the Booking > Settings > Fields page in your form fields customization,
    please replace this code:
    <div style="float:left; width:300px;">
    to this code:
    <div style="float:left; width:230px;">

    and this code:
    <div style="width:900px;">
    to this code:
    <div style="width:700px;">

    Thanks a lot for your help on that! I do have another question for you…

    At the Booking > Settings > Form content data showing in emails and inside approval and booking tables in booking calendar page, I cannot customize the[select]&[checkbox]fields.
    When I get the confirmation email, those fields don’t show up properly and are empty.
    Same thing when I go to my Bookings list, even if selected, I cannot see what the picked service was (Preferenza Contatto, Servizio and Superficie)…

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    At the Bottom form in the Booking > Settings > Fields page,
    You are need to use instead of this shortcodes: [select] and [checkbox] the shortcodes in format:
    [my_select_name] and [my_checkbox_name], if you are used at the TOP form these shortcodes:
    [select my_select_name “value 1” “value 2”] and [checkbox my_checkbox_name “”]

    Perfect! … Last question (I promise!)
    The Submit thank you message doesn’t show up anymore … How can I restore it?

    Plugin Author wpdevelop

    (@wpdevelop)

    If you are have active some payment systems at the Booking > Settings > Payment page (at Business Small and higher versions), the “thank you” message/page is not showing, instead of this will show the payment form.

    Otherwise, please recheck your configuration of the “thank you” message/page at the General Booking Settings page.

    I have Business Small. No payment page settings .. but the message still doesn’t show up …

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Labels width and hight’ is closed to new replies.