Support » Plugin: Child Theme Configurator » L10N Issues

  • Resolved Alex Lion

    (@alexclassroom)


    Hi Developer,

    I found some localization issues, I listed them as the following.

    1. Strings Missing Text Domain
    child-theme-configurator\includes\forms\files.php, Line 58

    child-theme-configurator\includes\forms\webfonts.php, Line 20, 25

    child-theme-configurator\includes\forms\parent-child.php, Line 102

    2. Strings should be localized but can’t be extracted

    Click to edit functions.php: child-theme-configurator\includes\forms\fileform.php, Line 24

    Click to edit files using the Theme Editor: child-theme-configurator\includes\forms\fileform.php, Line 24

    Upgrade Offer, child-theme-configurator\includes\forms\addl_panels.php, Line 37

    Please check them and maybe more issues happen actually, hope you could kindly fix them all.

    Thanks a lot.

    Alex

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author lilaeamedia

    (@lilaeamedia)

    It looks like the .pot was not updated prior to the 2.4 release. Checking into this now.

    Thanks,

    Alex Lion

    (@alexclassroom)

    This is not POT file issue, all issues must be fixed in the source code.

    For example, after adding the missing text domain, the localized strings will be displayed normally. This kind of strings can be extracted correctly, but they can’t be displayed normally because they don’t have corresponded text domain in the source code.

    • This reply was modified 10 months, 1 week ago by Alex Lion.
    • This reply was modified 10 months, 1 week ago by Alex Lion.
    Plugin Author lilaeamedia

    (@lilaeamedia)

    I can now see what you are describing. Thank you for taking the time to point this out.

    Poetic justice for all the times I have berated other plugins for similar oversights.

    Look for an update shortly.

    Thanks,

    -jf

    Plugin Author lilaeamedia

    (@lilaeamedia)

    These have been addressed in v2.4.1. Thanks for identifying these.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘L10N Issues’ is closed to new replies.