Support » Plugin: MANGOPAY WooCommerce » KYC doc upload form BUG

  • Resolved actopix

    (@actopix)


    Hey,

    I just updated the Mangopay Woocommerce plugin and now the store settings page of WC Vendors Pro doesn’t work anymore…

    It seems directly linked with the new KYC doc upload form witch appears in the store settings page of a vendor. The page is not fully loading (the footer isn’t loaded).

    I tried to register a new vendor but the problem is still the same.

    I really need help on this.

    Thanks

    Mangopay infos :
    Environnement actif : «Sandbox»
    ID client : Présent !
    «Passphrase» : Présent !
    Connexion à l’API MANGOPAY : Succès !
    Version de l’extension MANGOPAY-WooCommerce : 2.3.0
    Extension WooCommerce prérequise présente & activée : Succès !
    Version de l’extension WooCommerce : 3.1.1
    MANGOPAY activé comme passerelle de paiement WooCommerce : Activé
    Au moins un type de carte ou une méthode de paiement activé : Succès !
    Les «commandes invités» de WooCommerce doivent être désactivées Désactivée
    La devise actuelle de WooCommerce est gérée par MANGOPAY : EUR Acceptée
    Extension WC-Vendors prérequise présente & activée : Succès !
    Version de l’extension WC-Vendors : 1.9.12
    Version de l’extension WC-Vendors Pro : 1.4.4
    Bibliothèque PHP mcrypt disponible : Succès !
    Ecriture possible dans le répertoire du fichier de clé : Succès !
    Ecriture possible dans le répertoire temporaire : Succès !
    Tous les vendeurs actifs ont un compte MANGOPAY : Succès !

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author mangopay

    (@mangopay)

    Hi, thanks for bringing this up and we’re sorry for the problem. Are you able to check your PHP logs to provide any clues? And are all your plugins up to date?
    (We’re unable to reproduce the problem so we don’t have much to work with at this stage :-/ )

    Thread Starter actopix

    (@actopix)

    Hi, I checked the PHP logs and there’s no error with the plugins php files.
    All my plugins and theme are up to date.
    You mean you can access the page http://yoursite.com/pro-dashboard/settings/ ?
    Because if you can then it would come from my configuration.

    Thread Starter actopix

    (@actopix)

    Hi, I also have a 403 forbidden error when I try to add a KYC document.

    Hi gents,
    I get a similar issue: when I activate the mangopay plugin, it kills the vendors dashboard in a similar way. I only see the KYC upload feature.
    In my case, on top of the wc-vendors, I use the WC Vendors PRO plugin, is it the case for you Actopix ?
    I have the feeling that it is related to the Pro version of the plugin…

    Hi,
    I solved my problem by editing the main.inc.php file.
    I’m not a dev expert, I only did a bit of reverse engineering, so I’ll try to explain it in a comprehensive way:
    In my case the first section <div id=”store”> was enveloping the other sections/tab of my page (payment, branding, shipping…) so when I was clicking another tab, the id “store” was flagged with the class hide-all, and therefore was hiding the contents in the other tabs.
    So I had to insert a </div> in the page to stop the store section at the right place, before the payment section in my case.
    To do that, I add a “$html.= ‘</div>’;” at line 529 of the main.inc.php, after kyc submit operation, as below:
    $html.= ‘</div>’;//pv_shop_kyc_container
    $html.= ‘</div>’;// __Line added__
    $html.= ‘</div>’;//kyc_form_block

    Hope it helps.

    Thread Starter actopix

    (@actopix)

    Hi Patrol74,

    Yes I’m also using WC Vendors Pro above WC Vendors.

    Thanks for your feedback ! I’ll try this fix and I let you know if it works.

    Plugin Author mangopay

    (@mangopay)

    Ok thanks for all the infos everyone – we’re looking into this and will release a patch asap.

    Hi experts,
    I have still issue when registering a new user: if it can help, here is the log:
    2017/08/01 11:18:48 [error] 30649#30649: *577 FastCGI sent in stderr: “PHP message: PHP Fatal error: Uncaught MangoPay\Libraries\Exception: Unexpected response. Missing PersonType property in /xxx/xxx/monsiteweb.com/public/wp-content/plugins/mangopay-woocommerce/sdk/MangoPay/ApiUsers.php:299
    Stack trace:
    #0 /xxx/xxx/monsiteweb.com/public/wp-content/plugins/mangopay-woocommerce/sdk/MangoPay/ApiUsers.php(61): MangoPay\ApiUsers->GetUserResponse(Array)
    #1 /xxx/xxx/monsiteweb.com/public/wp-content/plugins/mangopay-woocommerce/inc/mangopay.inc.php(1535): MangoPay\ApiUsers->Get(”)
    #2 /xxx/xxx/monsiteweb.com/public/wp-content/plugins/mangopay-woocommerce/inc/main.inc.php(451): mpAccess->get_mp_user(”)
    #3 /xxx/xxx/monsiteweb.com/public/wp-content/plugins/mangopay-woocommerce/inc/main.inc.php(395): mangopayWCMain->kyc_doc_upload_form_func(Array)
    #4″ while reading upstream, client: 1.2.3.4, server: monsiteweb.com, request: “GET /dashboard/?terms=1 HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.1-fpm.sock:”, host: “www.monsiteweb.com”, referrer: “https://www.monsiteweb.com/&#8221;
    2017/08/01 11:18:48 [error] 30649#30649: *577 FastCGI sent in stderr: ” /xxx/xxx/monsiteweb.com/public/wp-includes/class-wp-hook.php(298): mangopayWCMain->kyc_doc_upload_form_doaction(”)
    #5 /xxx/xxx/monsiteweb.com/public/wp-includes/class” while reading upstream, client: 1.2.3.4, server: monsiteweb.com, request: “GET /dashboard/?terms=1 HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.1-fpm.sock:”, host: “www.monsiteweb.com”, referrer: “https://www.monsiteweb.com/&#8221;

    Hi patrol74,
    Can you tell us, your process? I can’t reproduce the problem on my version.
    I understand from your previous message that you use WCV pro. But i’m interested when this error occurs.
    Is it when you register on wordpress or on a checkout, as a vendor or client?
    what is mangopay configurationfor “all vendors” “all sellers”?

    Hi,
    I quickly set an instance with the standard theme Storefront to check if it’s not a problem with my theme, but I get the same issue.
    But, as per your question, I found the following:
    Issue occurs when:
    I first register a user on wordpress (only a login/password and email is required): he’s registered as a contributor only.
    Then I click on the “Pro Dashboard” link, and I’m stucked after the shop description field.
    If I register the first time using the whole form with name/address/birthdate… it seems to work.
    All vendors are businesses, all buyers are individuals, but using other settings doesn’t change the behavior.

    That’s very interresting.
    The thing with this pluigns is normally you can not register without passing by the complete form which have the hooks to add the “PersonType property”.
    You do the “first register” in a front form or as admin in the backoffice?

    I use the front form of my theme (I have the Handy theme from themeforest). Only user/password/email are required when registering.
    In the form, you can check a box to apply as a vendor and then right after the submit, you are redirected to the pro dashboard of the wc vendors pro plugin…and stuck…

    As I understand, I should have an intermediary step, to grab the mandatory details (birthdate, name, persontype…) before going to the pro dashboard…

    Well, you can add this use case in your specifications 😉

    Plugin Author mangopay

    (@mangopay)

    @patrol74, if I may say, I think your issue is unrelated to the original KYC form upload issue, so could you perhaps create a separate thread for it please?

    Plugin Author mangopay

    (@mangopay)

    Also, @aptrol74 – after investigation, we think that your error is very theme specific, so it would be a huge help if you could send us your theme so we can reproduce the issue and work on a bug fix – could you perhaps email it to us via the support page (mangopay.com/contact/). Thanks!

    I opened a ticket yesterday and uploaded the theme as discussed.
    Thx for your support

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘KYC doc upload form BUG’ is closed to new replies.