[resolved] Kubrick header uses the wrong background after 2.5 (6 posts)

  1. Andreas Aronsson
    Posted 7 years ago #

    I've recently upgraded to WP 2.5, and everything went smoothly, except that the Kubrick theme uses the wrong background for the blog, though I think it's because of WordPress.

    On the main page (http://andreasaronsson.com) it uses kubrickbgwide.jpg instead of kubrickbg-ltr.jpg, which means it's completely white instead of using a tone of gray for the sidebar.

    I've located the variables it checks at line 17 in header.php, in the default Kubrick 1.6 theme.

    if ( !empty($withcomments) && !is_single() ) {
    When this is true, it uses a background where the sidebar is gray. So it would seem something is wrong, as I only get the single-post background, all the time... :/

    I've tried upgrading my blog twice, on different systems, and I end up with the same problem both times. With and without plugins.

    ? :(

  2. Michael Fields
    Posted 7 years ago #

    I just deleted the "!empty($withcomments) &&" and it seems to work.

    I called isset() on a post that had comments and the variable was not set. I also looked in a wp2.5 xref and the variable does not seem to be defined anywhere.

    Please let me know how this works for you.

  3. Andreas Aronsson
    Posted 7 years ago #

    It worked :) should have tried myself.

    I guess (hope!) that variable isn't needed anymore!

    Thanks :p

  4. Michael Fields
    Posted 7 years ago #

    I did a pretty good scan of the source before posting and am pretty sure that this variable is no longer active. If anyone knows differently, please post.

  5. AdrianB
    Posted 7 years ago #

    I just upgraded a blog to 2.5.1 and at the same time I used the default theme from 2.5.1 to get a fresh theme. I was hit by exactly the same bug, my front page did not use the correct background. I traced it to the same line:

    if ( !empty($withcomments) && !is_single() ) {

    Then I compared to what was in my old default theme:

    if ( !$withcomments && !is_single() ) {

    I assumed there's a reason for this change, right?

    If I switch back to the old version everything seems fine. And according to this thread the $withcomments variable isn't even used anymore. Can anyone confirm this?

  6. christmasboy81
    Posted 6 years ago #

    I just created a ticket for this issue: http://trac.wordpress.org/ticket/7121 See the ticket for the research I did.

    I think the proper fix is if ( empty($withcomments) && !is_single() ) { although for most people reverting to the old line isn't a problem.

Topic Closed

This topic has been closed to new replies.

About this Topic