WordPress.org

Support

Support » How-To and Troubleshooting » Kubrick Header for WP1.5

Kubrick Header for WP1.5

  • Hello

    Yes there have been threads about this but kubrick template on 1.5 is totally different to 1.2. I can’t seem to remove the text and make it a clickable link cause it isn’t the same code as the one used on wp1.2.

Viewing 10 replies - 1 through 10 (of 10 total)
  • afaik its the same changes but just in header.php

    I have tried that and it doesn’t come out the same unless I am doing something wrong.

    heres how to make the header clickable – http://fernando.dubtribe.com/archives/2004/10/10/make-my-head-a-clickable-link/

    and to remove the text in the header remove this code
    <h1><a href="<?php echo get_settings('home'); ?>"><?php bloginfo('name'); ?></a></h1>
    <div class="description"><?php bloginfo('description'); ?></div>

    from header.php

    How do I make the entire header clickable? Currently, only the header text functions as a link…
    A: Open index.php. Change line 59, from <div id=”header”> to <div id=”header” onclick=”location.href=’http://siteaddress/’;” style=”cursor: pointer;”></div>. This will make the entire header a link.

    I did exactly this and it worked except made everything below the header move to the left of the page.

    Also,
    Q: How do I remove the blog name and description in the header? My header image already has all that…
    A: The best way of doing this, is to open wp-layout.css. Find the first entries you can find for ‘H1’ and ‘.description’. Now add ‘display: none;’ to the values in there. The reason for doing it this way, and not by simply deleting the code in index.php, is that this way around, it will degrade gracefully if an old browser happens to drop by.

    I can’t find this wp-layout.css.

    ok ignore the post ontop of this ok did all that and nearly working except I have a huge gap from the header to first post.

    Here is my blog: http://www.kastanaras.com/blog/

    Both ways should work, I can only imagine youve broken something (missing or extra div or something).

    Theyve worked flawlessley for me before.

    try removing the code from header.php as I said to get rid of the text

    try changing
    <div id="header" onclick="location.href='http://www.kastanaras.com/blog/index.php';" style="cursor: pointer;"></div>
    <div id="headerimg">

    to
    <div id="header" onclick="location.href='http://www.kastanaras.com/blog/index.php';" style="cursor: pointer;">
    <div id="headerimg"></div></div>

    Well here is bottom part of header.php page.

    </head>
    <body>

    <div id=”page”>

    <div id=”header” onclick=”location.href=’http://www.kastanaras.com/blog/index.php’;” style=”cursor: pointer;”></div>
    <div id=”headerimg”>
    </div>
    <hr />

    ok fixed thanks somefool.

    youd inadvertently removed some /divs there

    no problem

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Kubrick Header for WP1.5’ is closed to new replies.