• Resolved raefwolfe

    (@raefwolfe)


    Using event calendar WD as a widget, when I swap views between day/week/list/month, I get the following error.

    ksort() expects parameter 1 to be array, null given in [..]plugins\event-calendar-wd\includes\ecwd-display-class.php on line 977

    I have no idea what’s causing this error. I believe, specifically, it happens when I swap to ‘week’.

    https://wordpress.org/plugins/event-calendar-wd/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am having the same issue after I updated. not good this happened. How can I get the previous version? Or the fix

    Go in the .php file who return the error ( wp-content/plugins/event-calendar-wd/includes/ecwd-display-class.php )
    At line 977 replace :
    if ($events) {
    with
    if ($this->events) {

    everything should work after this modification ^^

    Sona

    (@support-web-dorado)

    Dear users,

    We are working on an update right now. It will be released soon to resolve all of the stated issues. Meanwhile remove the plugin from your wp-plugins section using ftp. Sorry for the inconvenience faced. It is related to the older version of PHP used in your sites, the issue is not present with sites using newest version of PHP. Thank you for your understanding.

    Sona

    (@support-web-dorado)

    Dear users,

    The update is already released. Please download and install it to resolve the issues.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘"ksort" error’ is closed to new replies.