Support » Plugin: Germanized for WooCommerce » Kompatibilität mit WooCommerce 3.2

  • Resolved dspaete

    (@dspaete)


    Hallöchen,
    gibt es schon ein (ungefähres) Datum für die Veröffentlichung einer mit WooCommerce 3.2 kompatiblen Version?
    Besten Dank!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author vendidero

    (@vendidero)

    Hi,

    wir sind bereits Woo 3.2 kompatibel 🙂

    Grüße

    Dann interpretiere ich “kompatibel” mal so, dass in Version 1.9.5 schon noch der seit WooCommerce 3.2 veraltete, direkte Zugriff auf z.B. WC_Cart->fees oder WC_Cart->taxes erfolgt (ich bin in der /woocommerce-germanized/includes/class-wc-gzd-checkout.php) statt über die Getters und Setters, die Ursache eines Fatal Errors im Checkout aber wohl nicht im Zusammenspiel WooCommerce/Germanized zu suchen ist.

    Plugin Author vendidero

    (@vendidero)

    Hi,

    nein, das interpretierst du wohl falsch. Ich denke du beziehst dich auf die Methode “do_fee_tax_calculation_legacy”? Das “legacy” in der Methode deutet darauf hin, dass diese Methode nur dann aufgerufen/ausgeführt wird, wenn es sich um eine ältere Woo-Version handelt. Das wird über die Prüfung:

    if ( method_exists( $cart, 'set_fee_taxes' ) )
        return;

    sichergestellt. Wenn diese Setter-Methode zur Verfügung steht wird stattdessen die Methode “do_fee_tax_calculation” verwenden um die anteilige Steuerberechnung zu ermöglichen.

    Insofern du weiterhin Probleme mit den getter/setter von WC()->cart hast, müsstest du wohl andere Plugins kontrollieren.

    Grüße

    • This reply was modified 1 year, 11 months ago by  vendidero.

    Stimmt, besten Dank! Toller Support!

    Hi,

    ist es bereits kompatibel mit Woo 3.2.1, ich möchte sichergehen, ob ich updaten kann?

    danke mo

    Plugin Author vendidero

    (@vendidero)

    Hi,

    das habe ich doch hier bereits geschrieben – ja das Plugin ist kompatibel mit WC 3.2 bzw. 3.2.1

    Grüße

    danke und sorry, ich hatte vorgestern noch die fehlermeldung, dass es nicht kompatibel ist und dachte es liegt an meinem 3.2.1 statt 3.2, jetzt ist alles fein,
    ganz lieben dank!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Kompatibilität mit WooCommerce 3.2’ is closed to new replies.