Support » Plugin: Slimstat Analytics » Known Users not logged

  • Resolved psn


    Hi Camu,

    Since I upgraded to your latest version Known Users is not logged. I have an other plugin Wordfence where I cleary can see several of our Members has login and visit site but they are not showned in Stat.

    I have not changed settings so I assume something has gone wrong in the latest version?


Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Jason Crouse


    What’s the site?

    Hi Camu
    I think I might found the problem, by mistake when I put in define('WP_MEMORY_LIMIT', '64M'); I uncommment define('WP_CACHE', true);

    So I comment back this cache and now I get stat for Members on our site.

    But if thats 100% true I don’t know so here you have our site:

    Something strange is it Yesterday I had 1 Known user logged in to our site and I could see him on stat as Known Users whith his nick name. Today when I check I can still see his visit in Right Now but not as Known Users, his track is now classed as Other Humans. I had in settings activated Outgoing click which I now have turned off, can that part generate tracked known users to be other humans??

    Edit: The above mentioned senario I can now understand why this happen its due to when known users logout and they will switch from known to other human as session is set to 1800 for 1 IP:s visit to remain. When I filter on his nick name I get his as Known Users.

    Also worth to mention when I had the above cache uncomment in config file I got one users track as above but an other known users IP which was logged in wasn’t tracked at all so the latest version might be instable?

    Edit: This users track when I filter on his IP or Nick name his track is not logged at all.

    I hope above information will help you to drill down to root cause as I love your stat and really want it to work 🙂


    Last Senario I might found the issue, when users visit our site from SmartPhones like Iphone or other we have connected WP-Touch for these and they are not tracked at all. I have tested this by myself and clearly these visit is not tracked. WP-Touch has a function where we can put in a code snipe for tracking purpose like Analytics or other can provide so can you also provide this code snipe into your plugin we can test and see if this will work!


    Plugin Author Jason Crouse


    Hi Per,

    as long as the template calls wp_footer(), no extra code should be needed.

    Please feel free to resolve this issue, if the problem is not occurring anymore.



    wp_footer is called and actually before your update it worked fine and its not working so plse investigate why visit from ios is not working.

    Have you tested your plugin after latest release with vistor from iPhone or other smartphones?

    Strange, now its working even showing stat from iPhones. Must be a setting as I changed following:
    Javascript-mode from yes to no
    Ignore users from yes to no
    Extend sessions from no to yes
    Activate CDN from yes to no

    Plugin Author Jason Crouse


    I would say it was Ignore users 😉 And also the CDN, which is currently updating…

    Actually the translation in Swedish was not correct so it wasn’t Ignore Users it was Ignore Spammers I changed so then I assume it was CDN. But anyway now its working as it should.

    JUst a short quest, I saw that JsDelivr has a plugin for serving js files do we need that to get this CDN function to work?

    I have now tested more deeper and the issue that iPone or other wasn’t tracked is due to JavaScript Mode Yes. I don’t have any cache plugin so I have that turned off but then we also got spammers, search engines and crawlers in the log. Can we have a function to just ignore these 3 and nothing else?

    Plugin Author Jason Crouse


    Try setting JS mode to YES but CDN to no.

    Have already tested that and then no ios or smartphones will be logged in stat. But for the 3 above it will work.

    So its something I belive you need to look into asap.


    Plugin Author Jason Crouse


    It’s working just fine on both my dev and production sites, so it must be some kind of conflict on your end. What’s the URL?

    I have now both JS mode and CDN set with NO

    I have changed JS mode to Yes and CDN is still No so now you should be able to see on your side what can cause this conflict.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Known Users not logged’ is closed to new replies.