Support » Plugins and Hacks » Known Plugin & Theme Conflicts with NextGEN 2.0

Known Plugin & Theme Conflicts with NextGEN 2.0

  • Plugin Author photocrati


    We want to post and keep updated a list of known plugin and theme conflicts. If you have these plugins installed and are having issues, these may be the cause, so try deactivating them and see if that resolves the issue for now.

    If you are aware of a plugin conflict or have details on the ones below, please add any details.

    Note that if you are having major issues with 2.0, you can safely rollback to 1.9.13:


    BBPRESS. Can cause site crash. Triggers error that looks like: Fatal error: Call to a member function get() on a non-object in /home/content/deletedactualpath/wordpress/wp-includes/query.php on line 27

    MAGIC FIELDS PLUGIN. Can cause site crash. Triggers error that looks like: Fatal error: Call to a member function get() on a non-object in /web/content/wp-includes/query.php on line 27

    SOLILOQUY SLIDER PLUGIN. This may cause aspects of our interface to disappear, especially when adding galleries to pages/posts via the new Attach to Post interface.

    CONTACT FORM 7. Still trying to determine the effects on this one. I think I’ve seen one example where it seemed to trigger major errors, and another where it just interfered with gallery displays.


Viewing 15 replies - 16 through 30 (of 128 total)
  • Plugin Author photocrati


    @everyone – thanks for posting your reports here. It’s very helpful.

    Another one:

    MAPPRESS EASY GOOGLE MAPS. This one causes NextGEN short codes to stop working and causes the Attach to Post interface to be blank when trying to add galleries.

    Big thanks to user GMSPSH for finding it.

    I ran across two problems, first was mainly because of the development environment (using a different port than 80) and NextGen Gallery is sripping the port out of the url.

    i change the following function to make it wordk with a custom port.

    function construct_url_from_parts($parts)
    		$retval =  $this->object->join_paths(
    			isset($parts['scheme']) && $parts['host'] ?
    				"{$parts['scheme']}://{$parts['host']}".(isset($parts['port']) ? ':'.$parts['port'] : '') : '',
    			isset($parts['path']) ? $parts['path'] : ''
    		if (isset($parts['query']) && $parts['query']) $retval .= "?{$parts['query']}";
    		return $retval;

    and the second problem was when no querystring was present (home page)
    the following fixed that problem for me
    (nextgen-gallery\products\photocrati_nextgen\modules\router\class.router.php )

    function get_querystring()
    		return isset($_SERVER['QUERY_STRING']) ? $_SERVER['QUERY_STRING'] : null ;

    With regards to the rollback option —


    Some of us – aka myself – are unsure of how to properly “create a full backup” of our site … Is there a tutorial on this somewhere?

    2.0 crashed my site with the following conflict ….
    Fatal error: Call to undefined function is_user_logged_in()
    in /home/mbyc2641/public_html/wp-content/plugins/member-access/lib/MemberAccess.php on line 217

    … looks like a conflict with the Member Access plugin which is mission-critical for me. Will rollback to previous version.

    NexGen Gallery Optimizer causes images to load solo (replaces the website) in the current browser window with NexGen 2.0.

    I deactivated it and the gallery started working again, without the fancy lightbox properties.

    Going back to the old version until all these issues are resolved!

    Plugin Author photocrati



    Just adding a couple more notes here.

    ELEGANT THEMES. We’ve seen some reports of menu drop downs having issues with some Elegant themes.

    ATTITUDE-MODIFIED. NG 2.0 seems to break the home page slider built into the themes.

    THEMES WITH SLIDERS. There is at least one other case of a theme with built in home page slider not working.

    The users of Elegant Themes http://elegantthemes.com/ are also experiencing issues. The main front page slider stops working. (This is a prominent feature in most of the ET themes).

    Ya, you guys need to fix that asap… it’s taken down more than 1/2 my sites that use that plug in!! Never had a problem with this plug in before, ever.

    Plugin Author photocrati


    @denisechapman: can you please provide more details. What do you mean by “taken down” your site, and do you know what conflict triggered it? Thanks!

    Plugin Author photocrati


    GREAT REAL ESTATE INTERFACES. There seems to be a conflict with this plugin that triggers an error on activation: Fatal error: Call to undefined function nggshowgallery() in /home/cdanyluk/public_html/wp-content/plugins/great-real-estate/interfaces/interface-nggallery.php on line 28″

    Plugin Author photocrati


    @wesyah234: thanks for the details about Elegant Themes. I’m basically updating our issue on this to indicate that theme with Sliders, including elegant themes, are having conflicts. Thanks.

    It’s taken down the galleries.. some just display errors… some are now running vertically… and I use themes from all over.. going through a list of 40 sites right now… you should just roll it back until you fix the bugs so we can easily apply the update as this is a pain in the butt. Have always LOVED this plug in.

    Plugin Author photocrati


    MORE FIELDS. if you try to upgrade to 2.0 with this plugin installed, you’ll get white pages on the both the front and backend pages. The users solve the issue by migrating to Advanced Custom Fields plugin and upgraded fine.

    @edradour the reason custom fields don’t work any more is because you had to change the gallery-view.php which is no longer there… 😀 I took mine off luckily I didn’t use it that much yet…. For me using the WordPress Media options which work fine.

    Using Mantra theme and had no problems with the slider on that theme..so might want to have a look at how they do their slider…

    The only problem I came across was Albums not listing correctly so had to go in and re-add each album again…a pain but it is a quick fix for something that small compared to other problems… 😀

    Kriss 🙂

    Version 2.0 does not support Ecclesia Theme (LINK). There should be a possibility to turn off permalinks as in the older versions. Without permalinks it works fine.

Viewing 15 replies - 16 through 30 (of 128 total)
  • The topic ‘Known Plugin & Theme Conflicts with NextGEN 2.0’ is closed to new replies.