Support » Plugin: WP Knowledgebase » Knowledgebase page causes theme layout issue

  • Resolved bobbyscon

    (@bobbyscon)


    I’m pretty sure the issue may lie with my theme, but I’m very new to WordPress and working with themes and plugins, so I’m hoping someone can at least point me in the right direction. I really like this plugin, so I’m hoping this is an easy fix!

    If you look at this page, http://rcsjackson.com/knowledgebase/ and compare it to my other pages running different plugins, http://rcsjackson.com/faq-2/ , it’s pretty easy to see what the problem is. The Knowledgebase portion of the page is off center and the footer is in the middle of the page. If I enable the search bar at the top and the breadcrumbs, you can only see half the search bar and the breadcrumbs aren’t visible at all.

    I created the page and selected the “KBE” template. Do I need to focus on finding the issue within the kbe_style.css or do I need to figure out something within the theme’s css that could be causing this problem? I’ve been messing with a few of the margin settings in the kbe_style.css file, but that just seems to move the knowledgebase around and doesn’t impact the footer placement issue.

    Thanks in advance for any insight!

    https://wordpress.org/plugins/wp-knowledgebase/

Viewing 12 replies - 1 through 12 (of 12 total)
  • OK, so what I’ve found so far is that the KBE template appears to be overriding come of my theme’s css. If I add min-height: 667px; to the kbe_style.css file, it starts to look a little better (footer is more towards the bottom, but the top of the KB stuff is still cut off), but it’s static and not dynamic. The container class of the theme uses a min-height: auto; setting, but I tried that in kbe_style.css under the #kbe_container class and there was no effect. Should I be putting it somewhere else?

    So the page with the Knowledgebase plugin in it has all of the content placed in the header div rather than a content div. I have tried messing around with kbe_knowledgebase.php and closed the header tag and added a content div, but nothing I did seemed to have any effect.

    Using Chrome developer tools, I manually edited the header under the Elements tab to close after the END TOP BAR comment, and that resolved the knowledgebase section being cut off at the top, but didn’t resolve the footer issue. This change is only there during the session, though, and I don’t know where to make this change in the actual code so that it sticks.

    I have deactivated and reactivated the plugin, as well as made sure I have the latest version.

    Plugin Author Maeve Lander

    (@enigmaweb)

    Hi Bobbyscon, I’d love to help but your site appears to have a block on it so when I try to view it I am redirected to a login screen.

    Unfortunately without viewing the issue I can’t really see what you’re referring to and can’t help much. Are you able to post a working link please?

    To give some general information that may help… When you activate the WP Knowledgebase it will copy it’s template files and CSS to your active theme. You will need to adjust the KBE page template that has been copied to your theme, as well as the CSS, in order to have full control over how the WP Knowledgebase appears on your site. In 95% of cases it will look pretty decent out of the box or maybe just require basic tweaking of the CSS… but it sounds like in your case you may need to do some more extensive layout and styling work in those files. If you are not confident with web development yourself then I would suggest to hire a developer for an hour or two. This sort of styling work is outside of the scope of support for this plugin, however if you would like to contact me privately to request such help then you can do so at enigmaplugins.com

    Thanks.

    Thanks for responding, Maeve!

    I’ve opened the site back up. Sorry about that, I was testing some login options. I totally understand the limits that can be provided for free via this support page, so I’m grateful for any guidance you’re able to provide. I have coding skills, but my experience in php and CSS is minimal, so it’s taking me a while to navigate the files. Hiring someone isn’t an option (no budget and the site is just a temporary proof of concept), so I’ll be working on it myself. Plus it’s a good way for me to learn!

    When you say “adjust the KBE page template”, which php file are you referring to? I can see, using developer tools, that there’s a mismatch on the page with the knowledge base compared to the other pages as far as which elements are contained within which <div> tags, and it appears that on the offending page the content and footer is all ending up in the <header> rather than a <div id=”content”> section.

    Thanks for the help!

    OK, I got it!

    I had been trying to edit kbe_knowledgebase.php thinking it was the template for the parent page. What I actually needed to work on was archive-kbe_knowledgebase.php. I’ll have to make the same changes to the other php files, but at least I know what I need to change now.

    FYI, there’s an awesome plugin called What The File that indicates which php file is powering a site, which is how I made the discovery above.

    If anyone else is using the Zerif-Lite theme, I changed the archive-kbe_knowledgebase.php file from this:

    <?php
        get_header();
    
        // Classes For main content div
        if(KBE_SIDEBAR_HOME == 0) {
            $kbe_content_class = 'class="kbe_content_full"';
        } elseif(KBE_SIDEBAR_HOME == 1) {
            $kbe_content_class = 'class="kbe_content_right"';
        } elseif(KBE_SIDEBAR_HOME == 2) {
            $kbe_content_class = 'class="kbe_content_left"';
        }
    
        // Classes For sidebar div
        if(KBE_SIDEBAR_HOME == 0) {
            $kbe_sidebar_class = 'kbe_aside_none';
        } elseif(KBE_SIDEBAR_HOME == 1) {
            $kbe_sidebar_class = 'kbe_aside_left';
        } elseif(KBE_SIDEBAR_HOME == 2) {
            $kbe_sidebar_class = 'kbe_aside_right';
        }
    ?>
    
    <div id="kbe_container">
    
        <!--Breadcrum-->
        <?php
            if(KBE_BREADCRUMBS_SETTING == 1){

    To this:

    <?php
        get_header();
    
        // Classes For main content div
        if(KBE_SIDEBAR_HOME == 0) {
            $kbe_content_class = 'class="kbe_content_full"';
        } elseif(KBE_SIDEBAR_HOME == 1) {
            $kbe_content_class = 'class="kbe_content_right"';
        } elseif(KBE_SIDEBAR_HOME == 2) {
            $kbe_content_class = 'class="kbe_content_left"';
        }
    
        // Classes For sidebar div
        if(KBE_SIDEBAR_HOME == 0) {
            $kbe_sidebar_class = 'kbe_aside_none';
        } elseif(KBE_SIDEBAR_HOME == 1) {
            $kbe_sidebar_class = 'kbe_aside_left';
        } elseif(KBE_SIDEBAR_HOME == 2) {
            $kbe_sidebar_class = 'kbe_aside_right';
        }
    ?>
    
    <div class="clear"></div>  <!-- added this -->
    
    </header> <!-- / END HOME SECTION  -->  <!-- added this -->
    
    <div id="content" class="site-content">  <!-- added this DOES NOT HAVE A CLOSE div TAG! -->
    
    <div class="container">  <!-- added this -->
    
    <div class="content-left-wrap col-md-12">  <!-- added this -->
    
    <div id="primary" class="content-area">  <!-- added this -->
    
    <div id="kbe_container">
    
        <!--Breadcrum-->
        <?php
            if(KBE_BREADCRUMBS_SETTING == 1){
        ...
        ...
        ...
        </div> <!-- added this -->
        </div> <!-- added this -->
        </div> <!-- added this -->

    I have also started using a child theme, so I had to place the modified php template file into the child theme folder rather than modifying the file created in the parent theme’s folder.

    I am still noticing that the footer “jumps” when the page initially loads. If someone knows how to resolve that, I’d love to know!

    Plugin Author Maeve Lander

    (@enigmaweb)

    Awesome! Glad you got it sorted and thanks for sharing your solution in case others stumble across this thread. Nice work.

    Hi Bobbyscon,

    Hopefully you’re still being notified of these threads. I’m having an issue with this plugin. I’m using the most recent version which is 1.0.9. If you’re still using this plugin, could you please double check the code you said to replace. When I did what you suggested I get a blank knowledgebase page.

    Better yet, could you post the entire archive-kbe_knowledgebase.php code here so I can copy and paste. I too am using a child theme but from studiopress.

    Thanks

    Hi Bobbyscon,

    I figured out the problem. All I had to due with this latest version of the plugin (1.0.9) was to modify the index.php within the plugin folder.

    Check out this thread:
    https://wordpress.org/support/topic/css-still-failing-since-v-103?replies=26

    I’m having a problem with this plugin as well – the page cuts off maybe 1-2 letters on the right side of every line. I assume it’s a style-css issue, but I’m not really sure how to fix this. Any suggestions? I’m using the sydney theme. EG: http://www.vibrationresearch.com/university/knowledgebase/vn0011-mirror-vibration-evaluation-procedure/

    Plugin Author Maeve Lander

    (@enigmaweb)

    @vrucathy
    Please don’t hijack someone else’s thread for your unrealated issue
    Please also don’t double post. You already have 2 tickets on this exact issue so I’ve answered you there.

    Thanks for your help keeping the forums organised – it enables me (and other forum support people) to help everyone much better.

    My apologies, it was a mistake on my end.

    Plugin Author Maeve Lander

    (@enigmaweb)

    No worries, thanks for understanding 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Knowledgebase page causes theme layout issue’ is closed to new replies.