• Resolved sarahweb


    Hello for some reason our Klaviyo link with our website has stopped working – the klaviyo team want us to white list their user agent – which I am not overly happy doing

    I cannot see why this would suddenly change as they request via the REST API, as does many other people for accounting and fulfilment etc and they are still working correctly – for this reason I have not DISABLED rest API

    Any thoughts of what else I should be looking at ?

    I cannot see their requests being blocked within the traffic inspector either..

    Anyone else use klaviyo and has it working on latest versions klaviyo (3.0.3) and wp cerber (9.0) and WP (6.0)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author gioni



    For troubleshooting purposes, you have to check the Activity log, not the Traffic Inspector log, because it can be configured not to log some events and so you can miss the critical ones. I would recommend searching the Activity log for the IP address of the Klaviyo service (server) or using filter “Request to REST API denied” from the drop-down list.

    Thread Starter sarahweb


    Thanks they are unable to supply me with an IP Address – but I have also checked full activity log and nothing there either – its only using the v3/products API GET request that seems to be the issue

    Would that be any different from v2 post or get requests as far as cerber goes?

    Thread Starter sarahweb


    On more investigation I have found actually that it was a plugin conflict that was stopping klaviyo working – I compared to our staging site (which worked when testing with postman) – comparing live and staging I was able to deactivate the plugins that were different and work out which one was causing the issue! – for us it was WC Currency Switcher
    I used postman to test against
    I have not had to change any settings within wp cerber at all
    Info for anyone else

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Klaviyo & wp cerber – issues API no longer working’ is closed to new replies.